[UNOFFICIAL][RK3228/RK3229]Libreelec builds

  • Hi foxy,

    please try to be a little more specific.

    This is to avoid the stupid question like.. "are you sure you have a rockchip rk3228"?!

    for example, can you tell me if libreelec starts from the sd card!? and the multitool?! Are you just having problems installing it on internal storage?!

    Finally, could you send some photos of the board contained in your box?! MXQ PRO 4K can also contain amlogic or allwinner chips.



  • Hi jaum20,

    the startup error is very strange.

    I see the kernel tries to set the gpu clock to 600Mhz which my build does not.

    Did you use the dts of my build!? or someone you adapted!?



  • I didn’t touch the files after writing the image to the SD card. I had to mention that I have an Armbian SO installed on the internal memory of the board. Can this be the source of the problem?

    Edited once, last by jaum20 ().

  • Hello, I just purchased a libre computer renegade, roc-rk3328-cc board. I have tried downloading several of these images to try, but I cannot get any of them to load.



    I have tried flashing them to an sdcard using the libreelec usb-sdcreator. When I boot the renegade, I get a red power light and green card read light on, but that's it. I don't get any video activity, and it doesn't seem to boot the card. Is there something I am missing with these images?

  • ilmich

    Thank you. It booted fine after replacing the dtb. Should I switch the dtb after install as showed on the post #2?


    I have a question, how did you install armbian?! Via usb cable, or multitool, or what?!

    I used jock's multitool.

    Edited 3 times, last by jaum20 ().

  • Hi jaum20,

    try this build. It's a preview of the next update that I decided to do to include the fix for your problem.

    Index of /test/

    Keep in mind one thing though. Your problem is related to a boot component of your armbian installed in nand.

    I won't go into too much detail but basically you have an opensource trustos (optee) that is loaded on boot (If you look at the log you sent me, the errors related to 'sip v2' are related to the fact that the opensource trustos is probably not compatible).

    Libreelec instead uses the proprietary one because it gives you the possibility of having ddr3 scaling and startup via remote control.

    Therefore, if you should have problems in this sense, the only solution is, in your case, to update the trustos you have in the nand. But this might give you problems with armbian.

    If I remember correctly, armbian also switched to using the same trustos as libreelec at some point (maybe jock2 can help us with that).

    So maybe the solution is even simpler and consists of some update that you can easily apply.

    Should I switch the dtb after install as showed on the post #2?

    yes, mainly this is needed in order to configure leds and some other features.

    Thanks a lot and let me know


  • @bemenaker, my builds are for rockchip rk3228/rk3229, not for rk3328 I'm sorry.

    @pigwoz, you need to switch dtb as explained in the 2nd post ( "Initial Setup" section) using the one with suffix -ovclk.


  • THank you ilmich. I spent hours yesterday so buried into trying different things, I completely missed that part. Makes sense now.

  • ilmich thank you for your work. Can you help me to get rclone to run in this build? I downloaded the latest version for am7 from rclone site, installed network tools from LE repo, but it do not installed fuse3:

    Fatal error: failed to mount FUSE fs: fusermount: exec: "fusermount3": executable file not found in $PATH
  • Hi jaum20

    this is normal because libreelec 10 has an older version of fuse.

    I can add it to my build, but can you please try this first (symlink to old fusermount)?

    VolumeDriver.Mount: failed to mount FUSE fs: fusermount: exec: "fusermount3": executable file not found in $PATH · Issue #6844 · rclone/rclone
    What is the problem you are having with rclone? Using the volume plugin in 1.6.2 fails with missing dependency I guess the plugin was not updated to fuse3?…



  • I had to create the soft link in the addon folder, because /usr is read-only:

    ln -s /usr/bin/fusermount /storage/.kodi/addons/virtual.network-tools/bin/fusermount3

    Thank you again

  • SCISHION V88 4K andriod TV BOX (1G/8G)



    boot from SD Card

    Why I can't customize my IR remote keytable/scancodes with putting relevant files in /storage/.config/rc_maps.cfg and /storage/.config/rc_keymaps/ (Infra-Red Remotes - LibreELEC.wiki)

    Тhe problem is that some buttons don't work.

    LibreELEC:~ # ir-keytable
    No devices found

    Should it be fixed here ? :

    LibreELEC.tv/linux-9000-rk322x-dts.patch at libreelec-10.0 · ilmich/LibreELEC.tv · GitHub

    Edited 2 times, last by dmladenov ().