[UNOFFICIAL][RK3228/RK3229]Libreelec builds

  • Hi all,

    new build available with:

    - linux 5.10.128

    - added esp8089 wireless linux driver (experimental because I don't own a board with that chip)

    - added analog audio codec (this partially enable the a/v port). thanks jock2 for the patch

    - minor fixes and improvements



  • Hi i have a problem with a xt-MX4VR-V01 card i tried to flash ilmich libreelec 9.2 v88 vmars with armbian mooltitool tool on nand, i discarded when it asked for idb and everything was fine, everything worked wifi, remote etc. ... Yesterday I tried ilmich's libreelec 10 flash with the multitool but when it came to the idb option this time I didn't discard it, it did all the libreelec flash. When I restarted the box no longer starts even with the SD card with the multitool, it just has a very faint red light on. I tried the unbrick tutorial described in armbian by shorting nand pins with sd card with multitool but nothing to do does not boot. I tried with various rockchip instruments on windows, when I connect the box to the pc with a usb cable it already goes into maskrom mode without shorting the pins. I extracted the charger from the android firmware that I had previously installed on the box (RK322xMiniLoaderAll_V2.47_spectek_en_ddr2_rd_odt_171127.bin), I tried to flash the charger only but no idb errors failed. I also tried with the loader loaded in this forum (rk322x_loader_v1.10.256) but still nothing, download start failed error. I also tried flashing the Android 6 firmware which was on the box before, but still no idb errors. Then I tried with the tutorial described on armbian to update idb with linux operating system, I tried with a pc with os zorin but without success (I am totally inexperienced with os linux) there is still something I can do before throwing this box in the trash? Thanks and sorry for my bad English.

    Edited 4 times, last by antoniotnt ().

  • Ciao Antonio,

    this kind of boxes are hard to soft brick.

    Have you tried with another USB cable?!



  • Hi thanks for the reply, I was able to resurrect the card. The thing going into maskrom mode by itself without shorting the pins made me think that maybe there was something making contact with the pins. So I gave him a good clean with a tooth brush 😂. I tried to reconnect the card to the pc with the usb cable and it did not connect, so I re-connected the usb cable then I pressed the reset button I short-circuited the pins and I connected the usb and it went into maskrom mode, with the android tool tool I flash the loader and it went ok then flash the android rom, after 100% by magic the blue light turned on. Now I have succeeded with the moltitool armbian a flash libreelec 10 on nand. I'm testing now. I wanted to ask something I am trying an xbox dvb adapter with tvheadend server but in the tvheadend configuration there is no dvb adapter. I searched a bit on google and read something about crazycat drivers but I didn't find them in the libreelec repository, I can download them somewhere and if so what is the procedure to install them. Thank you.

  • Hi Michele thanks for the reply, I still haven't checked for the xbox tv tuner because I found some bugs. 1) Sometimes after starting the system no sound. 2) After 5/10 minutes of use the system freezes, the key selector goes up and down like crazy when I move the remote control or the keyboard and the clock stops at the time of freezing. I am using dtb v88 mars i think it is best for me the lights, remote control, wifi and mediacom bluetooth adapter work. I attach the link of the log, log.txt and videoLog.txtVideo.zip. Thank you. http://ix.io/44HG .

  • Hi,

    for audio there is a problem with new installations (thanks for report). Having added the analog output, it uses that by default.

    If you manually select the hdmi audio output from the settings you should be ok.

    For the freeze, I have a board identical to yours and I don't have these problems.

    Are you using the normal dts or the overclocked one !?

  • Thanks always for your availability. I am using the normal mars dtb v88 no overclock. I wanted to ask something I tried to install tvheadend server 4.2 from the libreelec repository but in the settings of tvheadend it just tells me dvb-t and dvb-c the dvb-t2 does not find it. I checked on google and the xbox tv tuner is dvd-t2. Maybe it will be something about the drivers? From the dmesg | grep dvb tells me this:

    Are the drivers for xbox tv tuner already present in librerlec 9.2? For freezing maybe I have to try some

    other dtb, but the v88mars looks the best. Always thanks for your availability.

  • the driver seems to work well.

    for tvheadend dvb-t and dvb-t2 are the same thing.

    in the wizard select dvb-t and try to scan channels.

    for freeze.. try another dtb and let me know.

  • hi remlei,

    my builds by default use a generic device tree.

    The supported devices are only customizations for various leds layouts and ddr3.

    So you can try first the generic one to check if all works well, and then try another dtb to find the best for your device.

    If you don't find the right one I'll try to produce a dtb for v88 mars 2 (link for official android firmware are appreciated).



  • Thanks Mich for everything you do for us, now your latest build is almost great for my Mxq pro Rk 3229 box. On Samba I can now log in, reboots are not so frequent anymore, the temperature remains quite low at only 72 degrees, but I have two problems, the first I also had with the official version 9 and that is that if or because the source of a video was slow and freezing for a moment then it happened that it was difficult to recover and at most he recovered but only with audio. the second problem is that if on the system I set the analog audio that rage works if I turn off every reboot it goes back to standard audio and I have to manually reset to analog to send the audio to my external speakers.

    For the rest now and it's almost like the official version, thanks.

  • thanks MIKMXIII , these days I'm improving the temperature management, also adding the throttling of the gpu.

    it has never happened to me, and no one has ever managed to give me a log, but with my builds the kernel restarts the board when the temperature exceeds the 100 degrees celsius.

    but let's say that, thanks also to latest evolutions of the opensource mesa 3d driver, the board is much better than when I started this project (I'm experimenting with a build of lakka 4.2 and I'm quite surprised)

    as for your problems, unfortunately if you use streaming, but the source is not stable there is little you can do.

    on the analog audio switch, honestly I don't use it daily, but I'll do some tests and let you know

    Thanks again

  • Great Mich you are doing a great job with these boxes and if the best ones are still great, but can I change in the settings files and set the analog audio by default? so to solve my problem, I bother with each reboot to enter the system to change the audio.

    Thanks again

  • hi MIKMXIII,

    sorry, but I'm on a short vacation and can't try.

    Anyway keep in mind that mine is just a build of libreelec for tvbox rk322x.

    So in the meantime, for this type of configurations you can try to look for them also in the kodi documentation

    Userdata - Official Kodi Wiki



  • Hi, my box is MXQ 4k Pro 2Gb ram 8Gb rom rk3229 sv6051p. Lost the firmware cz of heat, fixed it installed better cooler and reflashed it with a firmware but cannot find a compatible one that would read 2gb ram for this one, will this custom rom help? Sorry new here.