MEcool KII Pro s905d 2gb version, dead bricked, Purchase in 2020, Help Required

  • Help Required - android TV box is dead after flashing wrong

    MEcool KII Pro s905d 2gb version Purchase in 2020

    By mistake or lack of knowledge, I have flashed wrong rom, from then it is not booting on, only blue light is there, no desplay on screen, when powered on.

    After that flashed different stock rom .img files from PC using USB, by pin shorting method.

    USB tool shows flash is successful, but still there is no desplay, only blue light

    Please suggest what can be done to get it working....


    see attachment for more detail....


    ROM


  • please suggest flashing method also, to use... :)

    Of course, you need to use USB burning tool and a USB A-A cable.

    The contacts do not need to be shorted, just press and hold the button on the bottom of the PCB when connecting the USB cable.

  • my box has no desplay on tv, changed hdmi also, it does not goes in to recovery mode when lover button pressed through pin, triad sd card burning method, it also does not worked for me.


    only pin shorting method is working, it' detect the box, and shows flashing successful, but still no desplay on TV / box does not boots only blue light lits up when powered on.

  • Dear sir

    i do not have micro comp. level knowledge

    if any guide is here or supporting tutorial i can follow it step by step

    to check what happened to my box..

    or solve the issue.....

  • Without a soldering iron and a TTL converter, you cannot determine what is causing the error.

    Unfortunately, the description is not enough for this now, it also requires some physical tools.

    • Official Post

    If you flashed a ROM built from boot FIPs with the wrong acs.bin for the RAM in the box (acs.bin has the RAM timing data) the early boot stage will not be able to reach the point where u-boot loads; so it errors and cycles to try again (ad infinitum). To get past this you need to prevent the eMMC being detected, because if it's detected, it's used. The "nice" ways to override the boot logic are an Amlogic SDIO debug board (almost nobody has one) or custom HDMI dongle (almost nobody has one) or you need the "less nice" shorting pins on the eMMC chip method. It's ugly but it temporarily disables eMMC and the boot logic then looks for u-boot on an SD Card or USB stick.


    The next steps involve experiments with shorting the correct pins and different u-boot(s) on SD cards so basically you need to UART hooked up to see what works and what doesn't work. It's fiddly but not actually that complicated once you mentally get over the idea of stuffing a screwdriver into your expensive cicruit board :)

  • thanks chewitt sir ,

    for replying ,

    i understood nothing,

    Please tell me what can i try or do next to get the box working again...

    currently i am arranging ttl adapter as suggested by dtech sir....


    Regards,

  • i understood nothing

    chewitt

    I think your description has become a little too detailed. :)


    s4shail

    Could you clean the top of the memory chip with something? (Like isopropyl alcohol or brake cleaner.)

    And then you should take a good quality macro photo of the caption on it.


    This is the memory chip on your PCB:

    (For better readability, use the flash, but do not place the camera perpendicular to the PCB.)

  • Well, it's still a little hard to read, but I managed to recognize it.

    This is a 2GB LPDDR3 memory chip from Samsung. It was important information.


    Okay, the next step will be when the TTL adapter arrives...

  • s4shail

    I have an ATV9 version for this device (experimental), but it works fine. I will send you the download link later by PM.

    It looks like you created a short between TX and GND, check this out. Furthermore.. run a driver search in the device manager..

  • I see two mistakes on your photos:

    • The 3.3V pin of the device is never connected, especially not for the 5V pin on the TTL adapter side.
      This pin is only used to power the TTL adapter, but it is actually already gets it from the USB port.
      However, it can be dangerous for the device if 5V is applied to pin 3.3V of the UART.
      (See illustration in post #6 -> the 3.3V pin is not connected.)
      Solution: Please desolder the red wire from the KII Pro.
    • The Windows driver installed for the device is not compatible. (See the yellow triangle.)
      There are a lot of fake Prolific TTL adapter ICs that are not supported by the official driver.
      Solution: You must install the driver recommended by your seller, or if it does not exist, you must request one.

    But, if the IC is a real one, the exact type is also important. Please download the PL2303 CheckChipVersion tool and check your chip ID.


    For example, mine is: