LE 9.2.6 no video on install

  • I downloaded LE9.2.6 for Raspberry Pi 4B using LibreELEC.USB-SD.Creator.Win32. When I start the RPi, I see the RPi startup screen (color palette), but the LibreELEC startup screen never appears. I have only the HDMI cable, Ethernet cable, and power connected to the RPi. (There is no difference when I connect a mouse and a keyboard.) The RPi is aware of the Samsung TV connected to the other end of the HDMI cable, because the TV is not complaining about "No Signal".


    Installing RaspOS (using an image on a different SD card) works as expected. While running RaspOS, I updated the EEPROM on the RPi 4B to the latest version.


    I found a recent posting on this forum, with title "No vidéo Signal" , which talks about mismatch related to EDID, but his person was able to get LibreELEC to work enough to capture logs.


    I have tried to use a computer monitor, but the only ones that I have support only VGA and Display Port. With a Display Port / HDMI adapter connected to the HDMI cable from the RPi, I do not even see the RPi startup screen.


    It seems to me that a basic property of an OS is to find the display(s) in its environment and display on it/them. So, I am very puzzled by the inability of LibreELEC to display anything on my screen. My RPi 1B is getting a bit long in the tooth, and I was very much looking forward to using my new RPi 4B. BTW, the RPi 1B, with the same level of LiberELEC (9.2.6), has no difficulty displaying on this TV.


    Can anyone give me any hints as to how to resolve this problem?

  • Make sure you have the HDMI cable connected to HDMI0 port on your RPi 4B - it's next to the power connector.

  • Yes, it is. The TV is aware of the RPi (and vice versa), because I see the startup screen, and the TV does NOT complain that there is no signal on the HDMI port. And yes, the HDMI cable is plugged into the HDMI port that is closest to the power connector.

  • I will try this tomorrow; I have downloaded the .gz image (full install) rather than the .tar image (update). I need to prepare an empty SD card.


    However, to be clear, what I am describing above is happening in an initial install of LibreELECl. The install gets past the RPi firmware (EEPROM), because the color palette is displayed. However, the LibreELEC logo is NOT displayed. I cannot tell if LibreELEC is aware of the screen. The TV thinks it is connected to something that is sending it a valid HDMI signal, but the LibreELEC kernel may or may not be able to access the screen.


    Question: Is there a (kernel) log somewhere on the SD card that I can examine if I remove the SD card and plug it into a desktop computer (either Linux or Windows)?

  • One additional fact: the RPi is perfectly aware of the same TV screen when the SD card contains RaspOS---everything works perfectly.

  • I have done further investigation.

    If I place the SD card that has been imaged with LibreELEC-RPi4.arm-9.2.6.img into an SD card reader in a Linux environment, I can see that it contains two partitions:

    1) A FAT-formatted partition containing the initial load

    2) A non-FAT-formatted partition, whose root folder contains one file:

    .please_resize_me

    and one directory:

    lost+found

    The fact that the second partition has NOT been re-sized, and the fact that nothing appeared on my screen after the RPi startup screen, implies to me that the initial run of the "installer" on the SD card has failed.


    I tried again, this time downloading the LibreELEC-RPi4.arm-9.2.6.img.gz image directly from the libreelec.tv site, and using BalenaEtcher to write the SD card. (The previous time, I had used the recommended SD Card Creator.) I got exactly the same result.


    RaspOS (as noted previously) works perfectly, so the hardware is not at fault. I used RaspOS to determine what the hardware version is.

    Code
    The Board Revision displayed by raspi-config is:
    
    Raspberry Pi 4 Model B Rev 1.4

    So, I have a perfectly functioning Raspberry Pi, version 4B, and the supplied image on the LibreELEC website for the Pi 4 does not work.

    I am prepared to collaborate with anyone who will work with me, but I have no clue what tools I might use to discover what is going wrong. Can anyone help?

    • Official Post

    If you have RaspOS running, update the RPI + USB firmware if still necessary.


    Try booting RPi+LibreELEC on a (non-4K) PC monitor or other TV to see if the basics work.

    Resizing partitions manually can also be done with tools like GParted.

  • I have downloaded the .gz image (full install) rather than the .tar image (update).

    Yes you are right, sorry for the wrong link.


    Can you also try to write the LE image to USB stick and try to boot from it if it's the same issue?


    Try booting RPi+LibreELEC on a (non-4K) PC monitor or other TV to see if the basics work

    A couple months ago I experienced LE (yet installed) couldn't boot with some older AOC PC display (with DVI-D and VGA inputs only) connected through HDMI/DVI-D adapter. As this display had also some strange issue with PC connected through DVI-D (it was not possible to set the resolution to 1920x1080), I did not try to fix / analyze that and trashed it.

    But maybe in this case I would try to boot RPi without any display attached to see if there's any progress at least with partition resizing.

    Edited 2 times, last by ghtester ().

  • ghtester suggested writing LE 9.2.6 to a USB stick

    - this had exactly the same result as using the SD card.

    Klojum suggested booting on a (non-4K) PC monitor or other TV.

    - I only have TV monitors that support VGA or Display Port. Using my HDMI cable and an HDMI/DP adapter resulted in nothing on the screen (not even the RPi startup screen).

    - I have only one TV that has HDMI.

    Klojum also suggested that I update the firmware using RaspOS

    - I had done this already; see my first post on May 5th.

    Since the RPi 4B worked fine with RaspOS, my supplier for the RPi suggested that I modify config.txt on the LE 9.2.6 SD card, to force the correct CEA mode (i.e., to disable auto-detect), but this also had no effect.

    Code
    hdmi_group:0=1 # Use CEA
    hdmi_mode:0=16 # mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive


    Finally, ghtester suggested using the nightly build for LE 10. This solved the problem, but puts me on the bleeding edge, with alpha software. I have no problem with this, but the other users in my house are not as comfortable with technology.


    Clearly, there is something that LE 9 does not do, and LE 10 does do, in the boot-up sequence, that is getting in the way of successful initialization of a new system card. If anyone can put me in touch with the appropriate system development person(s), I would be happy to serve as a debugger, to determine where the failure is. Perhaps the fix is something that could go into LE 9.2.7...