No video output from new RPi4b

  • I just bought myself a brand new shiny CanaKit RPi4B, case, fan, power supply, HDMI cable etc.....The only item that I used of my own was a known good SD Micro card. One that I know works and that I pulled out of another known working RPi4,

    I wrote a brand new download of LibreElec v9.2.6, plugged all into a known good Samsung TV (it used to have a RPi3B on it a year ago so I know its good). No video. HMMMM....I tried combinations of HDMI ports on the TV, and ports on the pi, nothing. I get another known good TV, nothing. Same procedure, swapping around ports, swapping out cables etc...I finally put the pi on a known good TV that is currently using a RPi4, works. I'm thinking perhaps these two TV's are no longer working as I thought they were, so I went out and bought a BRAND NEW TV, something that I know is good.

    I still don't get any video output. I decided that since I have a known good PI and a known good TV, that I could swap out PI's. Put the good PI on the new TV, and the new Pi on the other TV. No video output with the known good Pi and the new TV.

    I forgot to mention, that in between all of this, I re-downloaded LibreElec and re-wrote it to my card. I even swapped out the power supply with the known good power supply. Still nothing.

    Okay. This is telling me that there must be something else going on. At this stage there are no log files to look at, its still just a basic SD card with LiberElec written to it. What else can I look at, or tweak or adjust or IDK.

    Any idea's are appreciated.

    Thank you.


  • Please give the LibreELEC 10 beta 1 build a try - with LE 9.2 you need to add a bunch of settings to config.txt to override the video mode, the simple cmdline.txt solution only works with LE 10.

    If you connected a 4k monitor then it could also be that the HDMI cable is not specced for 4k - it's easy to find out though, LE 10 with the video mode option in cmdline.txt will start in HD, then you can try switching to 3840x2160 in Kodi (Settings->System->Display). If you get "no signal" on TV wait a couple of seconds, then kodi will automatically switch back to the previous (HD) mode.

    so long,


  • The cables that I have are rated 4k, at least the box say's so. This is interesting because I recently built RPi4 using v9.2.6 and it works just fine. I'm just wondering what makes this build different?

    I'll try the v10 and see if it works.



  • I am happy to report that LibreElec v10 Beta 1 is working. I'm a bit disappointed that the skin I use is not available, nor are a few other features, but I'm hopeful that they will be available once this go from beta to operational.


  • In my case it is my TV. It was "HD ready" not "HD". Very early in the US changeover. No CEC, no overscan, just aspect; the tuner defaults to analog, there is no "." on the remote; I have to go to the analog number then push the channel up to get the digitals.

  • Maybe I have a similar problem.


    - Raspberry PI 4b.

    - Monitor: Iiyama Prolite T2453MTS

    Now I did some really stupid. I followed (not) this advice and upgraded my Libreelec 9.26 to 9.95. After some struggeling everything worked (Hifiberry, TV Headend, Netflix, Simple IPTV).

    Only one thing has been left:

    When I installed the system for the first time, I dispaired when I tried to get the monitor running properly. There was no black no real colours. The picture was something grey.

    I fixed this with the setting in /flash/config.txt


    After upgrading to 9.95 this setting seems to be ignored somehow.

    vcdbg log msg:

    05725.815: HDMI1:EDID error reading EDID block 0 attempt 0
    005731.840: HDMI1:EDID error reading EDID block 0 attempt 1
    006982.194: hdmi: HDMI1:EDID error reading EDID block 0 attempt 9
    006983.228: hdmi: HDMI1:EDID giving up on reading EDID block 0
    007043.884: hdmi: HDMI:hdmi_get_state is deprecated, use hdmi_get_display_state instead
    007043.914: HDMI0: hdmi_pixel_encoding: 300000000
    007043.938: HDMI1: hdmi_pixel_encoding: 300000000

    tvservice shows:

    tvservice -l
    0 attached device(s), display ID's are :
    tvservice -s
    state 0x120009 [HDMI DMT (82) RGB full 16:9], 1920x1080 @ 60.00Hz, progressive

    tvservice -s should output:

    HDMI CEA (31) YCbCr full 16:9

    Trying to set this manually:

    tvservice -e "CEA 31 HDMI"
    Powering on HDMI with explicit settings (CEA mode 31)
    [E] Failed to power on HDMI with explicit settings (CEA mode 31)

    which seems logically because the monitor isn't detected anymore.

    How do I get my monitor recognized again?