getting log files

  • LE 10 LE on RPI 4B 1 gb. On installation the screen gets to the LE splash then goes black, seems to have crashed, but the USB is flashing. This is with a 2006 Polaroid 42 inch TV that does not have CEC or overscan, only choices for aspect.

    My solution is to modify the Config.txt to:














    Note that "include distroconfig" is deleted. Then adjusting the screen calibration in Kodi.

    Later today I will try to make a custom EDID. I think I tried that last year, to no avail.

    I have been advised that the parameters involved have no effect in LE10. But it works.

    I have been advised to file a bug report with logs included. How can I make logs if I can't get to Kodi?

  • Please start with a clean installation of LE10 and just add video=HDMI-A-1:[email protected] to the end of cmdline.txt (in the same line, separated by a blank from "quiet".

    This should get LE into a state where you have screen output and can grab logs and your edid.

    Note: if you had to add hdmi_force_hotplug=1 and manually configure hdmi modes it could also be that you have a defective cable - this isn't too uncommon and can lead to hotplug detection and/or edid reading not working.

    so long,


  • OK, your TV seems to be a "HD Ready" one with a 1366x768 panel inside. RPi4 doesn't support this mode, the kernel driver filters that out, but your edid seems to contain a detailed node entry which shows up as 58Hz in kodi log and isn't filtered out.

    Does it work if you append video=HDMI-A-1:[email protected] to cmdline.txt?

    PS: please use the "pastekodi" script to generate logs.

    so long,


    • Official Post

    The cable works fine with rpi3B and several other boxes. This is only on pi4 LE.

    I'm still skeptical about your HDMI cable. Chances are that RPi4B uses a higher data rate compared to RPi3B. You've been reduced data rate by using a custom config.txt, which made it work.

    Please check the HDMI version of your cable, it should be 2.0 or 2.1.

  • Upon another hour of experimentation it seems that the culprit is:


    Since you told me my parameters have no effect in LE10 I tried rebooting with one line commented 10 times. My new, working config.txt is:



    hdmi_ignore_cec=1 #comment this if yours has CEC






  • Sigh. If you disable distroconfig.txt and manually enable fkms the hdmi options will of course have an effect - but you should not do this.

    The thing I asked for is very simple: does the video option added to cmdline.txt on a clean LE10 installation, with unmodified config.txt/distroconfig.txt give you a working screen or not?

    If it works, please post a pastekodi log and your edid.

    so long,


  • The cable works fine with rpi3B and several other boxes. This is only on pi4 LE.

    As RPi 4B has micro HDMI connectors (different from RPi 3B's), I suppose there's not only the cable you reported working with RPi 3B but also some adapter which can reduce the signal quality as well...

    Also AFAIK the parameter gpu_mem=320 is obsolete in LE10 due to different drivers used and gpu_mem=76 should be enough.

  • I have run out of time today.

    What I did was go back to the original config.txt including distroconfig. Then started commenting one line at a time. Turned out that commenting "disable_fw_kms_setup=1".

    I have switched over to the Pi3b for the night.

    I have a BRAND new Micro HDMI adapter. Got it yesterday before whining here.

    Now it works except for Kodi keeps crashing. might have a connection. Thanks for the help.

  • Please stop messing around with config.txt and do the very simple thing I told you: start from scratch with a fresh installation and only add the video parameter to cmdline.txt.

    I'm very confident that adding that single option to cmdline.txt will solve your video problems and that the other issues you are seeing are caused by your messing around with config.txt / gpu mem / video driver etc settings.

    You can save yourself and me a lot of time by following the advice I gave you.

    so long,


    • Official Post

    I have a BRAND new Micro HDMI adapter. Got it yesterday before whining here.

    Hmm, that's no info about it's HDMI version unfortunately. I've seen some RPi3->RPi4 switchers, having no pic after the switch, and the cable was the issue.

  • This case is definitely not the cable. Ubuntu works, rpi OS works. No jittering, no lines. Works great with the modded config until I upgraded to LE 10 and it got overwritten.

    I will try the cmdline tomorrow AM. I am not ignoring you, I was doing stuff while you were typing.

  • The logs shows you still have all the old cruft you added in config.txt - again, drop that, this is not going to work and very likely causing your crashes.

    Replace your config.txt with the stock version from /usr/share/bootloader/config.txt and don't touch gpu_mem, distroconfig.txt or kms overlays.

    so long,


  • Thanks, this is looking good now.

    Keep the video= setting in cmdline.txt, this is the standard linux method to configure video modes (and work around video/edid issues) - see modedb default video mode support — The Linux Kernel documentation

    Out of curiosity: can you upload your edid? run

    cat /sys/class/drm/card0-HDMI-A-1/edid > edid.bin

    and then attach the edid.bin file - we'll have a look if it's possible to improve video mode handling in the driver.

    so long,


  • Thanks a lot for your edid!

    I gave it a try and got a picture with it, but it's skewed horizontally. Not really sure what's going on there, could be that my monitors can't cope with that mode, could be some odd issue in the video driver. I've contacted RPi devs.

    BTW: you could also try using video=HDMI-A-1:[email protected] - that will give you a mode that's closer to the probably native panel resolution and thus avoids down/up scaling from 1920x1080 or 1280x720 and may give a clearer GUI. Not all monitors/TVs accept that mode though.

    so long,