libreelec10 - No Audio on 3,5mm Jack

  • I use a Pi4 and would like to setup libreelec to use my "soundsystem". I had to install libreelec20 to run netflix and Prime. Now the Option to get the sound out of the 3,5mm Jack disapeared :C

    Can you help me with this?

  • Go to Best Answer
    • Official Post

    Libreelec20 .. Really? LibreELEC 10 is not even officially released yet.


    Options don't just simply disappear. Can you make a screenshot of the audio output section with the devices listing?

  • Options don't just simply disappear.

    I am afraid in this case it really "disappeared" between LE versions, AFAIK also some update in past (most likely some Nightly build a couple months ago) replaced the /flash/config.txt with some default one, different from previous so the original settings was lost.

    Perhaps the dtparam=audio=on should be included in /flash/config.txt by default as missing this audio output option (Analogue jack) is confusing many LE / RPi 4B users.

  • Very few users seem to have been using the analog audio output and those that did complained that the quality was bad, volume level quite low and/or that they got crackling audio during video playback (which are all known issues and to fix the latter audio_pwm_mode=1 is needed in config.txt which leads to even lower quality audio output). The simple solution in most cases was to use a cheap audio HAT or USB audio adapter instead.


    Therefore I didn't consider to enable on-board analog audio output by default in LE10 - the feature is still there though for those who want to live with the limitations.


    so long,


    Hias

  • Thank you very much for the advice with the Option in config.txt i would never find it myself.



    Sorry for the confusion with the Word "disappeared". I wanted to write after updating in the first place but caused it's not allowed to update to Version 10 and I also tryed it with a fresh install so i avoid writing i updated it.

  • What are you suggesting to use then for audio output if not the jack output? I have connected a projector over HDMI and it only has a tiny speaker. From the location of the projector I can't easily get the audio to the speakers. The audio jack has worked nicely for me so far, what would be an alternative?

  • Thanks for the advice. The HiFiBerry audio HAT has some nice features, in particular it promises a higher volume level. However I'd also have to get a new case then to make it fit, which makes it quite an investment.


    Found some documentation of the config.txt parameters and it suggests audio_pwm_mode=2 to improve the sound quality and to reduce hissing. Will give that a try before investing into more hardware.

  • Eventually cashed out a few bucks for a small mixer with USB sound card (Behringer Xenyx 302USB) Now I can connect several devices to my active speakers without fiddling with cables and the audio quality from the Raspberry Pi is so much better.


    Thanks again for pointing out that the audio quality of the analog jack is limited and that there's not much that can be done about it other than avoiding to use it.

  • I didn't pay too much attention checking for an Update on my PI4 and just took the latest.


    Besides I lost most all my NAS SMB Folders, now my 3.5mm Audio Jack sounds super-crappy.


    I added the Headphone Activation line listed above to my config.txt, which did turn on 'headphone'.


    The 3.5mm jack is on, but now the audio is really bad. Lots of 'new' static/choppiness in the audio. I'd suppose it's an incorrect Sampling Rate sound?


    Then I tried the 'audio_pwm_mode=1' setting. This seemed to make no improvement.


    I tried changing the '1' to a '2' and a '3'. That only resulted in a change in 'pitch' of the audio to make boys sound like girls. This may have cleaned up the bad sound, however.


    Is there more settings I can try to return the audio to it's pre-Matrix condition?


    Thanks!


    -KP

  • hello I also have the problem that my analog audio 3.5 does not work have already tried everything I can do


    I have dtparam=audio=on on config.txt


    Raspberry Pi3 libreelec 10 nihgly

    Edited 2 times, last by Teddychen ().