LE10 & TBS 5520SE on RPi4 // updated drivers [SOLVED]

  • [SOLVED]

    [EDITED 19/12/2022]

    last pre-compiled drivers for linux 6.1.0 and patches source code available here:



    COMPILATION instructions in the 3rd post:

    RE: LE10 & TBS 5520SE on RPi4 // updated drivers (SOLVED)

    Compiled drivers READY TO DOWNLOAD & INSTALL in the 6th post:

    RE: LE10 & TBS 5520SE on RPi4 // updated drivers (SOLVED)


    I've been using LibreELEC 9.2.6 with Crazycats drivers in a RPi4

    in order to give support for TBS 5520-SE receiver.

    Today, I've tested a nightly build of LibreELEC 10, but TBS 5520-SE is not detected, :(

    and Crazycat drivers are not available to select !

    Is there any plans for the Crazycat's driver with LibreELEC 10 ? Or TBS drivers ?

    (I've also tried to compile TBs drivers in the same x86 machine i've compiled LibreELEC 10 for RPi4, but not being lucky with the cross compiling ...)

    Edited 7 times, last by nvdias: Instructions for download and install drivers (December 19, 2022 at 6:35 PM).

  • Go to Best Answer
  • Hi smp , thank you very much !

    It worked in my RPi4 !!!


    I had to do some changes to adapt the directories to my Raspberry Pi4, from the thread you've referred above

    A quick summary for what I've done to put TBS 5520SE working with LibreELEC 10 in my Raspberry Pi4 - it my help someone.

    ( CvH , crazycat : The patch from smp is great to make TBS 5520SE Receivers to work with LibreELEC 10 ;))

    Note: I used a VM with Ubuntu running in my windows PC to cross compile a patched LibreELEC 10 image:

    - Clone libreelec 10 official git master branch:

    git clone https://github.com/LibreELEC/LibreELEC.tv.git

    cd LibreELEC.tv

    git checkout

    - Edit kernel config:

    Edit projects/Rpi/devices/RPi4/linux/linux.aarch64.conf


    add this line --> CONFIG_DVB_USB_TBS5520SE=m


    - Apply smp patch for TBS 5520SE:

    download from smp provided link in the above referred thread:

    wget https://www.dropbox.com/s/z8fphv11sfdpat5/linux-tbs5520se.patch?dl=1

    copy it into projects/RPi/devices/RPi4/patches/linux/:

    mkdir projects/RPi/devices/RPi4/patches/linux/

    cp linux-tbs5520se.patch projects/RPi/devices/RPi4/patches/linux/

    - Compile LibreELEC 10 and create image:

    PROJECT=RPi DEVICE=RPi4 ARCH=arm make image

    wait ... wait ... wait .... for some hours

    The image will be in .\target directory.

    use *.img.gz file and burn with libreelec sd-card writer tool.

    Edited 2 times, last by nvdias: kernel config file changed to linux.aarch64.conf (August 26, 2021 at 10:44 AM).

  • Failure here when compiling...


    frank@frank:~/LibreELEC.tv$ uname -a

    Linux frank 5.8.0-44-generic #50~20.04.1-Ubuntu SMP Wed Feb 10 21:07:30 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

    frank@frank:~/LibreELEC.tv$ gcc --version

    gcc (Ubuntu 7.5.0-6ubuntu2) 7.5.0

  • frankviana , my compilation was quite straight forward,

    but if you wish I can create a package with the compiled drivers that you can install as a kernel-overlay over a standard libreelec 10 running image for RPi4.

    Just give me until the end of day...

  • TBS 5520SE drivers for LIBREELEC 10 on Raspberry pi 4:

    (updated for kernel 5.10.52)

    Just download the zip file from this mega shared folder:


    Unzip it to your Rpi4, make the install script executable and execute-it:

    chmod a+x install-tbs.sh



    How it was done ?

    Compiled tbs 5520se drivers for libreelec 10.

    to be mapped as kernel-overlays.

    a) firmwares (*.fw) files in --> /storage/firmwares

    These firmware files will be loaded as new firmwares.

    b) driver (*.ko) files in --> /storage/.cache/http://driver.dvb.tbs/lib/modules/5.…/driver.dvb.tbs

    These are the new drivers to be mapped over kernel-overlays directory.

    c) 99-driver.dvb.tbs.conf --> /storage/.cache/kernel-overlays

    Will instruct libreelec to map these *.ko files at boot time.

    - To stop loading the drivers, delete the file:


    Edited 2 times, last by nvdias: updated to kernel 5.10.52 (August 26, 2021 at 11:00 AM).

  • Hi,

    I tried to install it for TBS 5955. The installation was successful, without any visible error. But TVheadend doesn't show USB TBS 5955 tuner.

    Can you help me, please ?

  • Hi,

    I tried to install it for TBS 5955. The installation was successful, without any visible error. But TVheadend doesn't show USB TBS 5955 tuner.

    Can you help me, please ?

    The patch that smp made seems to be only for 5520SE.

    Maybe he could help with 5955 too ...

    Btw, i've just updated the driver for the new kernel version that goes with last LE10 nightly builds (5.10.25).


    Edited once, last by nvdias: Merged a post created by nvdias into this post. (April 14, 2021 at 10:49 AM).

  • nightlies for now, till Beta2 is released

    I have librelec github cloned in my ubuntu.

    just git pull and compile as usual, or I need to change anything to include tbs 5520 drivers from source in rpi4 compilation ?

  • With the change suggested, compilation for RPi4 failed:

    - Compiled with:

    PROJECT=RPi DEVICE=RPi4 ARCH=arm make image

    - Returned error. Log here:

    Ubuntu Pastebin

  • My thanks to nvdias, smp and cvh for their work on this issue.

    I have realised that the tbs drivers are very kernel specific when I tried to compile them

    I have RPi4 and tbs5520se.

    I compiled releases 9.95.2 (kernel 5.10.27) and 9.95.1 (kernel 5.10.17) successfully, but neither will work with the nvdias overlay driver for kernel 5.10.25

    Sorry if a Noob question...

    How do I find or generate a libreelec image with a kernel 5.10.25, so I can use nvdias patch (from above)?

    or please point me to a libreelec image that will definitely work with tbs5520SE?

    Alternatively, how do I recompile the tbs drivers for a newer kernel?

    Someone said 9.2.6 works with Rpi4 ?? I'm greedy, I want 9.2.8 with widevine fix as well :)


  • unkrocks

    Just compile an image with my patch. Copy it to packages/linux/patches/raspberrypi and edit projects/RPi/devices/RPi4/linux/linux.arm.conf, add the line CONFIG_DVB_USB_TBS5520SE=m.