Trying to get sound through HDMI again

  • TL:DR Should an HDMI 1.4 cable work please?


    Among other things I am having trouble getting sound from my HDMI to TV.

    It worked from audio jack fine.

    I had a brand new official pi HDMI cable.

    Bit it was damaged.
    When I looked inside both of the hdmi ports of the 'brand new but off ebay' Pi4, the top left pins were sticking down.

    Prior to this I had tried using a little hdmi to micro adapter. This showed no video or audio.

    I didn't look inside the port before I used this adapter.

    When I realised my new official cable wasn't working, I looked closer and realised it was damaged.

    Then i realised that the top left pins were down and pushed into the plastic part of the cable.

    I pushed them up so they wouldn't do it again.


    I don't know if this could remove the audio if maybe I have pushed them too far?

    I am talking about the thicker metal pins. Not quite sure what they do, but look like they hold the plug in place? You know the ones?
    They go into the dimples on the outside of the plug itself.


    Anyway instead of spending a tenner on another new official cable, I have now been given an HDMI 1.4 just on the off chance that works.

    It doesn't.


    So, I thought I would check if the 1.4 should work with audio or not first please?

  • Just make sure to use the HDMI-0 port, the one on the far left.

    HDMI 1.4 supports upto 4K30 afaik.

  • OK, great, thanks.
    Right, so, I should be able to get audio with 1.4 in the left hand port next to the usb C?


    I have been having all sorts of fun.
    I feel like I have tried everything.
    But please assume I have tried nothing.

    You don't think that a) me bending up those pins, b) a damaged cable or c) a potentially faulty usb to sata cable could have caused any damage causing the lack of hdmi audio do you?

  • You don't think that a) me bending up those pins, b) a damaged cable or c) a potentially faulty usb to sata cable could have caused any damage causing the lack of hdmi audio do you?

    What do you want me to say? I cannot judge whether the ports of your RPi are still functioning properly.


    People should be aware that all ports of any Raspberry Pi should be treated gently.

    They are not the exhaust pipes connected to a typical car's engine block.

  • I just wondered if you might might know something about them from the information i gave.

    You might have come across a similar scenario.

    There are undoubtedly going to be people on the site that know more than me.


    So, from your reply, you don't the answers or the information I gave is not sufficient.

    One of those.

    I am not expecting you personally to be the font of all knowledge but hoping someone on the site might have more knowledge than me and be able to offer some insight to me.


    For example, (again, not asking you personally, just putting it out there to see if anybody knows) are the upper pins just there to hold the cable in place or do they serve a signal purpose. Or perhaps they are an earth? Or are they just there to do a mechanical job in hiolding the cable there maybe?


    I am a bit stuck and am trying to work out things and trying to hopefully get some help from somewhere.

    The upper pins were bent down. All that was happening with the pins in that position were that it was causing damage to every cable i put into it.

    They had to be moved or else throw the pi away. No HDMI cable could go into them.
    I am trying to find out if that might cause issues to the pi.
    If not, the pi is fine and so it is likely to be settings somewhere in libreelec.

    If that might be faulty I should look more into that first.

    It arrived in a new box.


    I have spent a few days trying to make it work and not being very successful.

    I can't make libreelec work.


    I am trying to find out how to make libreelec work.

    I have read and tried many different things on various sites and am stuck.

  • OK, found it.

    Well, somebody else found it for me.


    It is because I am using a tv.


    I had to make some changes in config.txt


    I had to change the HDMI group and mode to cea from dmt.

    Also it turns out i was in dvi mode, so had to change from dvi mode to hdmi.