LE-9.2.x build for some Amlogic S905, S812 and S805 devices

  • I tried to find a build solution for my devices to run the current stable version on them, because official support for Amlogic devices ended with version 9.0.2, at least with the old kernels. And the new mainline 5.x kernel still lacks some features to make it suitable for daily use.


    After a (very) long time, I managed to get them to work. Some example:

    • Mecool KI Pro (S905):
    • M8S+ (S812):


    Currently supported Amlogic SoC families and devices:


    1. Amlogic Meson GXL (S905X/D/W) SoC on Linux kernel v3.14.29 (LTS):

    • Mecool KI-Pro with S905D SoC (2G/16G) and a modular integrated DVB-T2/S2 tuner (AVL6862 with Rafael Micro R848/R912) :
      Working services: Power status LED (Blue=ON, Red=OFF), CPU temperature sensor, Analog+S/PDIF+HDMI sound output, Gigabit LAN (factory MAC address detection works), Wireless (2.4+5 GHz, Bluetooth), amremote (all buttons work), HDMI-CEC, NAND boot (installtointernal), Availink AVL6862 multi-standard internal tuner (native kernel support, dvb-latest, crazycat_aml).
      NOTICE: WLAN and bluetooth tested and works with both wireless modules: AP6255 and BCM4335B0 also work.
    • MXQ 4K Pro+ with S905X SoC (2G/16G):
      Working services: Power status LED (Blue=ON, Red=OFF), CPU temperature sensor, Analog+S/PDIF+HDMI sound output, 10/100 LAN (factory MAC address detection works), Wireless (2.4+5 GHz, Bluetooth), amremote (all buttons work), HDMI-CEC, NAND boot (installtointernal).
      NOTICE: WLAN and bluetooth tested and works with wireless module: BCM4334B1.

    Amlogic S905 images: Index of /S905/


    2. Amlogic Meson8/8m2 (S802/S812) SoC on Linux kernel v3.10.108 (LTS):

    • OTT M8S+ with Amlogic S812 SoC (2G/8G):
      Working services: Power status LED (Blue=ON, Red=OFF), CPU temperature sensor, Analog+S/PDIF+HDMI sound output, Gigabit LAN (factory MAC address detection works), Wireless (2.4+5 GHz, Bluetooth), amremote (all buttons work), HDMI-CEC, NAND boot (installtointernal).
      NOTICE: WLAN and bluetooth tested and works with both wireless modules: AP6330 and BCM4335B0 also work.

    Amlogic S8X2 images: Index of /S8X2/


    3. Amlogic Meson8b (S805) SoC on Linux kernel v3.10.108 (LTS):

    • MXQ HD18Q (1G/8G) a.k.a. "all black" versions:
      Working services: 10/100 Mbps LAN, Realtek WiFi 2.4 GHz, CPU temperature sensor, amremote (all buttons work), HDMI-CEC, NAND boot (installtointernal).
    • MXQ m201d (512M/8G) a.k.a. "all black" versions with 512 MB RAM only:
      Working services: 10/100 Mbps LAN, Realtek WiFi 2.4 GHz, CPU temperature sensor, amremote (all buttons work), HDMI-CEC, NAND boot (installtointernal).

    Amlogic S805 images: Index of /S805/


    4. Amlogic Meson6 (AML8726-MX) SoC on Linux kernel v3.10.108 (LTS):

    • WeTek Play (1G/4G) a.k.a. WP1:
      The device image is based on the officially supported version 9.0.2.

    WP1 image: Index of /WeTek_Play/


    +1 Bonus - Experimental images for 3rdParty devices


    Note: I don’t have these devices, so although I try to support, but I can’t test them directly.


    Notes:

    • The built-in LibreELEC packages for the devices are not installed from the official repo, because they are located on an external server.
    • The remote control configurations are integrated into the image for all devices, so those can be used immediately after the first boot.
      To install a remote control for an unsupported device, follow the instructions here: Index of /remote.conf/
    • Keep in mind that only "amremote" is supported, the "meson-ir" configurations for these images are not supported.
    • Using an external DTB only works with the S905/S905X/S905D, but also only when booting from the SD card or USB storage.
      If you want to boot from external storage with an external DTB, you can find it here: Index of /device_trees/.
    • External DTB cannot be used with Meson8* (S802/S805/S812), because there it only takes into consideration those that are integrated into the kernel!
    • If you use an external DTB to boot, you should NEVER install it to the NAND directly, because it will NEVER boot!
    • Support for tuners has been expanded in the release '2021-04-02' with the dvb-latest package.
      It is also the last updated and recommended driver package.
    • There is no guarantee for 3rdParty images because I do not have such devices, so I cannot test them.
    • It is possible that support for other devices and other Amlogic SoCs (eg. S912) can be created from this source, but unfortunately I do not currently have any time and resources to compile code for other Amlogic devices.


    Fix the "power-on bug" in uboot for some boxes (S8X2 only):


    This new power management option has been added since version 9.2.8.

    Enable this option only in case of detailed condition, otherwise it may cause a system error or data loss during shutdown.



    This option has been tested and works on an M8S box with M8S+ image (labeled: "AM8228 2G+8G 2016-03-19", PCB: "S812_M8_REV1.1 15/05/21").


    Known issues:

    • [ALL] slow channel change with 'pvr.iptvsimple'. (Kodi gets 0 fps from streaminfo when starting stream.) Fixed!
    • [S8X2/S805] playback freezes when it is stopped or rewind/forward is used, if the playback resolution is the same as the boot screen. Fixed!
    • [S8X2/S805] analog audio output (DAO) not working via AV jack. Fixed!
    • [S905] playback problems with VC-1 codec. Fixed!
    • [S8X2] audio passthrough issues. False positive!
    • [S8X2] device with bcm4335b0: the 5 GHz wireless and bluetooth stops working after power off or restart. False positive!


    The source files are available here:

    GitHub - dtechsrv/LibreELEC-AML: 'Just enough OS' for Kodi for some Amlogic TV boxes


    Requests:

    • If you find an error in the image, please report it in this thread.
    • If you tested an image on a device other than the devices I support and it worked, please indicate it here in the thread as well.
    • If you have a device that belongs to the supported SoC family, still feel free to write and I will try to find a working DTB for it.
    • If you have usable information for how to troubleshoot known issues, please post in this thread, or start a conversation with me, or send a pull request through GitHub.

    Thank you. ;)

  • Hi, I was just looking for an updated image for a M8S+.

    I installed it and it boots up and works (network/wifi/bluetooth all is present), but when I try to play a video from whatever video addon I only get a spinner.

    Looks very promising, hope you can fix the video playback !

  • Hi, I was just looking for an updated image for a M8S+.

    I installed it and it boots up and works (network/wifi/bluetooth all is present), but when I try to play a video from whatever video addon I only get a spinner.

    Looks very promising, hope you can fix the video playback !

    It was a clean install or an update?

    And which image did you use before?

  • I reinstalled the 9.2 version. Installed the Dumpert addon and played 2 video's. The first one worked, the second one froze kodi.

    It seems to have problems stopping video's and starting a new one.

    Maybe problems are Youtube related, I experience similar problems on a S805 device and your latest image. When I stop a video the box hangs itself.

    Files

    • kodi.log

      (139.42 kB, downloaded 74 times, last: )

    Edited once, last by gjstroom ().

  • I reinstalled the 9.2 version. Installed the Dumpert addon and played 2 video's. The first one worked, the second one froze kodi.

    It seems to have problems stopping video's and starting a new one.

    Okay, I guess what the problem might be. After startup, try changing the resolution to 1080p to 720p, and try playing the video and then rewinding or stopping.


    If the problem still exists, it will be different than what I'm thinking.

  • Okay, I guess what the problem might be. After startup, try changing the resolution to 1080p to 720p, and try playing the video and then rewinding or stopping.


    If the problem still exists, it will be different than what I'm thinking.

    Yes, resolution set to 720p fixes it !

  • Thanks, looks like it's fine now !

    One more issue, when using the Retrospect add-on no video shows until I pause and play. Any ideas about this ?

    Normal video playback from a smb share also works fine.

    I'm missing the hdmi audio outputs, only spdif and analog is listed at the audio settings. So can't do audio pass through.

    Edited 3 times, last by gjstroom ().

  • Thanks, looks like it's fine now !

    One more issue, when using the Retrospect add-on no video shows until I pause and play. Any ideas about this ?

    Normal video playback from a smb share also works fine.

    I'm missing the hdmi audio outputs, only spdif and analog is listed at the audio settings. So can't do audio pass through.

    I'm trying to find a solution for online video stream problems (like pvr.iptvsimple), because in Kodi 18.5+ the extraction of stream info has been pretty reworked, and amcodec doesn't really like that. (It reports 0 fps, 0x0 resolution, and it cause other anomalies when starting a live stream.)


    The "Default (analog)" seems to be equal to HDMI output, but I don't why. (The analog output has not worked since OpenELEC v6.)

    I also use it with this settings and it works properly without passthrough, but I will check the passthrough mode with my TV.

  • Hi dtech,

    I have an OTT M8S box with Ap6330 wifi module. I download your Libreelec v9.2.6 for M8S+ and install it on my box. It boots normally but wifi is disable ( no option for wifi). Do you have any idea to have the wifi turn ON. Thanks.

  • akican

    If I remember correctly, we’ve already talked about this in another thread.

    Then you wrote that there was a version that worked with wifi, just the power on did not work.

    You should copy dtb.img from that version to the SD card and try it out.


    gjstroom

    I added a couple of fixes, the new version has been uploaded to GitHub, it is available on the releases page. (9.2.6-20210209)

    I tried a few previous M8 audio configurations, but none of them changed the situation, only Analog and S/PDIF options are displayed in the ALSA list.

    I tried passthrough on M8S+ with basic settings, and my TV recognized Dolby AC3 correctly, but I couldn't try DTS because unfortunately it is not supported on the LG OLED TV.


    Another question: What kind of S805 device do you have? Maybe an MXQ-HD18Q (a.k.a. "all black" with 1GB of RAM) or an MXQ-m201d (512MB)?

  • You're right it does pass through ac3 and dts, I can't select anything for pass through, only the spdif lists (which makes sense). But hence I can't select the newer ACC and DTS-HD formats. No worries, this M8S+ is from a friend and he only has an DTS capable receiver, not the newer formats.

    My S805 is a M8S. About your 9.02 builds for both M8S and M8S+, they do freeze quite often. Not sure yet when, looks also stopping/starting video related. For the M8S+ the 9.2 build does a better job.

  • My S805 is a M8S. About your 9.02 builds for both M8S and M8S+, they do freeze quite often. Not sure yet when, looks also stopping/starting video related. For the M8S+ the 9.2 build does a better job.

    For M8S-S805 (M8Q) devices, I will also be trying to make an image soon, because there is the same problem with the initramfs script.

  • Hi dtech,


    your image is working great on my Mecool KII Pro - thank you very much for your work!

    Would it be possible for you to compile the makemkv addon to this release.

    I connected my external BDROM to the box for use it as BD Player also, but many of my original BDs

    are protected.

  • Thank you for the feedback. I'm glad it works under KII Pro as well.


    I tried to find something meaningful for makemkv, but what I found so far only included PKG_ARCH="x86_64".

    Does it work on Amlogic device at all? If you had such an earlier version, I would like a link.