Beelink Mini MXIII WIFI and BT

  • This is actually a great sign...this means it should work!!! Reboot and look for wireless under network

    Edited once, last by mytbyte ().


  • This is actually a great sign...this means it should work!!! Reboot and look for wireless under network



    Under connections in LibreELEC settings right??
    [hr]
    Horray it worked. Thanks for your patience in helping me. It means a lot.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

    Edited once, last by kodiuser1 ().

  • Under network you should have "wireless networks" selecion...disable it then enable it and you shoiuld have neraby wireless networks available under "connections"


    Oh, I missed that you made it work, I'm glad to help...now we wait to see if we get bluetooth support as well...this box only has 2 USB connectors, hate to loose one to the airmouse IR receiver...

    Edited once, last by mytbyte ().

  • I did have it working. I then did a reboot now no wireless networks are showing under connections or network. That sucks after all your work and help.
    [hr]
    Now I have it back up again.
    Any idea how to make it work every reboot without ash?
    [hr]
    Nope it won't pick up the wireless adapter on reboot.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

    Edited once, last by kodiuser1 ().

  • It happens every time with me if I disconnect the Ethernet.
    If I have Ethernet plugged in then it will bring up the wireless networks and I just have to uncheck wireless and re connect.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • Not with me...I disconnected the Ethernet, even dsabled it and wireless option is stil availble after reboots or power offs...I only need to deactivate/reactivate to get the availbale wifi networks...

  • Lucky for you. I've lost my wifi again and it didn't come back after a reboot.


    Do you think this will get fixed in another build or device tree?

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • I have been trying to make the kernel module for Aigaile chips load automatically but unfortunately I couldn't make it. The only thing I achieved is an easier hack:

    • first install this devel version - when updating from 7.0.2.009 you don't need a device tree: LibreELEC-S905.aarch64-7.0-devel-20161116235711-r23437-g73c3cef.img.gz
    • if you have the previous "hack" in autostart.sh, delete it - either the whole file or lines with the hack only
    • in Configuration folder (/storage/.config over SSH) enter modules-load.d directory and create file named wifi.conf and content cfg80211_qca. A SSH one-liner for this is echo cfg80211_qca > /storage/.config/modules-load.d/wifi.conf
    • reboot


    Please report if WiFi works "automatically" with this version and after following these steps.

  • Just to clarify @kazaq here is what I did:


    1) Updated to the latest devel LibreELEC-S905.aarch64-7.0-devel-20161116235711-r23437-g73c3cef.img.gz
    2) Created a file named wifi.conf with the following contents:

    Code
    1. [code]
    2. cfg80211_qca


    [/code]
    3) Put this wifi.conf file in the modules-load.d directory .
    4) Ran the following command via ssh putty:

    Code
    1. [code]
    2. echo cfg80211_qca > /storage/.config/modules-load.d/wifi.conf


    [/code]
    5) Rebooted.


    Once I did that I got the wireless networks tab coming up under network. The picture is a screenshot:

    However, even if I deactivate and reactivate the wireless networks, I still don't get any wireless connections. Like in the screenshot below:


    Hope this helps.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

    Edited once, last by kodiuser1 ().

  • Please let me know what you need and tell me how to collect a log and I'll do it around this time tomorrow for you with pleasure.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • Great I will try it. Thanks.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • Hi @kasaq.


    Here is what I did. I deleted the autostart.sh and the wifi.conf files.


    Updated to the devel in post #50.


    Rebooted. Box updated and rebooted.


    Went to Network. The wifi box is there still, but there are no connections.


    Here is my Log. Dropbox - Link not found

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

  • Ahh figured it out.


    Here you go.

    MXQ M10 S805 - LibreELEC 8.1.9
    NEXBOX A5 S905X - LibreELEC 8.1.9
    BEELINK MXIII II S905X - LibreELEC 8.1.10

    Edited once, last by kodiuser1 ().