Struggling to acheive HDMI sound (noob) (Xbox tuner now working)

  • Hi all,

    I am completely new to this and excited, but I am struggling a bit.

    I have been hunting for a couple of hours.


    I was told I could use the Xbox tuners with a Pi 4.

    I am running LE fine, have installed TVheadend and HDHomerun (open to suggestions if it can be done better)

    But I think my next step is to run HD Homerun, but it says there is no channels found on any device.
    I am thinking I haven't the drivers for the Tuners.
    Am I right or have I missed something?
    I am a bit confused.


    Thanks.

  • I am getting there slowly.

    I am struggling to achieve sound through my HDMI.

    I have now managed to achieve sound from the 3.5mm jack and USB.

    I have manged to achieve sound from my other pc through the same HDMI port in the TV.

    The cable is in the port next to the usb C.
    It is a new pi 4 (well new but from seller on ebay.)

    The cable is new Official Raspberry Pi 4 Micro-HDMI Cable - 1M from Pi Hut.

    I have tried changing the audio settings from hdmi to usb to analogue etc

    I can only now think it might be either the cable or the pi port.


    Does anyone have any other thoughts?
    I haven't got anything else i can test the micro cable on.

  • Thank you for that.


    Interlacing set to off.

    Switch output back to hdmi.

    Nothing.

    Reboot.

    Still nothing.


    As soon as I switch it back to usb, instant sound.


    I wish I could use the second hdmi port to see if that works.


    I will try a different OS now.
    I wonder if there is a way to use the second hdmi only as a test on the other os?
    I have had a quick look, but it seems complicated.

  • Well, i read so often that you can only use the one hdmi out......


    Turns out that is not correct.

    So, HDMI out works from the other port as well.

    Just not audio on either one.


    I have tried it with volumio and raspberry os as well.

    All sorts of variations.
    I think I have tried the lot.


    After many hours thinking it was settings, I think it might be the brand ne lead from Pihut.

    Unlikely to be just the audio on both ports on the pi i imagine.

  • If you go RPi -> AVR -> TV, then it's possible that the AVR is unable to pass-through the audio. In that case, try RPi -> TV. Trying another OS (Raspbian) is definitely a good idea. You can also try an LE nightly build.

    Flexin' vinyl, jammin' break beats. 8)

  • Thank you again.

    Good thought.


    I am just going Rpi to tv.


    I had a close look at the cable, it looks damaged at one side.


    Things are improving gradually.
    I can definitely see me liking this.
    Just takes some fiddling about to start with doesn't it?


    I got a Flirc usb which is working nicely.

    I had the sound coming through a usb DAC, but suddenly that has stopped being recognised which is a shame.
    Ah well, back to 3.5mm jack for now.


    I have currently got cables everywhere :)


    Also, it seems to run fine for a bit, but then loses signal.
    Out of the blue. Seems to work again once I power down for a bit.
    I checked cpu temp last time and it was only 47C.

    I'll add that to the list.

  • If you get the same trouble with another OS, I suggest to buy a new HDMI cable. Make sure it's HDMI 2.0 or 2.1 standard.

    Flexin' vinyl, jammin' break beats. 8)

  • Yes, thanks, I reluctantly agree.
    I went with the official pi cable, but the cost all keeps adding up.


    Another thing i need to work out is why does it keep freezing on me.


    Actually, this one might have been when it started recording.

  • If you get the same trouble with another OS, I suggest to buy a new HDMI cable. Make sure it's HDMI 2.0 or 2.1 standard.

    Also, thank you for that.

    I didn't know there were different ratings.

    I can't actually find what standard the official pi one is.


    Oh, wow, I see why you say it.
    There have been a lot of versions haven't there?

  • The RPi 4B has 4K resolution, so date rate will speed up. The HDMI cables are basically the same like on SD resolution, but on HDMI 2.0 / 2.1 standard (made for 4K) they have better shielding.


    Please test with Raspbian before you buy a new cable.

    Flexin' vinyl, jammin' break beats. 8)

  • I did test with Raspbian.

    Also with Volumio.

    Same issue.


    Can I please ask another question?


    How do i make recording destination my SSD?

    It just auto made it destination on first install. I have recorded a few things to it.
    I was just testing the concept with a small 8GB cheap SD card.


    Now I know it kind of works, I wanted to use my decenter quality and larger sd card.

    I backed up to the ssd no problem.

    Flashed LE to new sd.
    Restored the backup, no problem.

    Seems to have all the same add-ons.

    Now I can't see the recording I have on the SSD and when I look at tvheadend via 9981, the size available for recording shows that it is recording to the sd card.

    How do I change the recording path please?


    Thanks

  • OK, i found another thread at last.

    It tells me I can change it in TVHeadend.
    Which I thought was the case.

    But the trouble is, on the settings- storage, it ends 4P-...

    It doesn't seem to show the whole details unfortunately.

    Which looks just two digits short of the example in the link I found:

    ck :: Digital TV recording (even scheduled) made easy with Libreelec, Kodi and Tvheadend


    So, as I understand it, I can also change it with SSH which I have seen, but I haven't been able to work out what that means.

  • Thought it might be interesting how a noob finds it.

    I have spent hours doing google searches.


    I would be able to add in the details to the config on tvHeadend if the whole info was shown on the libreelec.

    I have struggled to find any guides.


    I have now found that I need Putty.

    So, good.


    I installed PuTTy, but couldn't now work out what the password i need.

    I think I got the login right, but am not sure how to know.


    Nope, stuck now on password.


    Am I meant to log in as the name that I gave my Pi?
    Or something else?


    I have tried using the name I gave.




    Ahhhhhhhh, another half hour and I found it.

    you login as

    root


    not [email protected] or the name you give it, or anything, just login as root.

    Just the word root.


    Right, now to remember which of all the tabs I have open, is what to do next.


    OK, found it.

    I think it is now recording to ssd.
    Although I can't find the recording that I made previously.

    So I can't delete it.


    So, my next question is, does its ummmm 'name' change each time I put it in?


    At least i have myself a bit of a guide here if I have to start it again.
    I am guessing I need to reformat it in my pc.


    Then on to the next of my list.

  • So, my next question is, does its ummmm 'name' change each time I put it in?

    Do you mean UUID? That will stay the same until you format it again.

    Flexin' vinyl, jammin' break beats. 8)

  • Well, I hadn't formatted the ssd.

    But I had changed the sd.


    So the ssd was still the same one.
    I would have thought those details would be on the backup that was saved to that ssd.

    Maybe not.


    Working on the next things in the list. I shall have to come back to that problem later.


    Another couple of quesitions please?


    1 Is it possible to set up so that I can watch tv if I lose internet access?

    Seems like the signal is coming through the tuners to the pi.
    Do I HAVE to have internet access to watch that signal?


    2 is there a guide to optimising your pi etc?

    3 I receive less channels through this system than before.
    Before I had worse cables and split the signal as well but had more channels.

    Some of the ones I now have are blank.

    Is there something I can do to optimise that or is it generally considered worse than when I used to plug the aerial into a pvr and a tv for some reason?


    Thanks.

  • Please open three new threads for those questions. We don't like the one-thread-for-everything idea (creates chaos).

    Open a thread for Q2 on the current sub-forum (General Support), and for Q1 and Q3 here (PVR & DVB Support). Thanks!

    Flexin' vinyl, jammin' break beats. 8)