VideoPlayer Segmentation fault

  • Hardware:

    - Intel NUC 8i3BEH with Intel Corporation Iris Plus Graphics 655


    OS:

    - LibreELEC-Generic.x86_64-9.80-nightly-20210124-164b0f6 and former


    Addon:

    - Tvheadend, pvr.hts


    description:

    after some time watching Sat-TV the screen gets increasing artefacts/stuttering with an subsequence black/crashed screen.

    on the same box LE (release 9.2.6) with TvHeadEnd 4.3 runs without errors.


    crashlog:

    http://ix.io/2Nea

    DigiBit R1, NUC8i3BE

    Edited 3 times, last by JoeAverage ().

  • tested with another box[*] and LibreELEC-Generic.x86_64-9.80-nightly-20210128-d3fc794.


    and again: VideoPlayer[1137]: segfault ...


    [*]

    cpu: Intel(R) Core(TM) i5-3475S

    graphic: Intel® HD Graphics 4000 (GT2)

    DigiBit R1, NUC8i3BE

  • If you continue to paste logs from both machines maybe someone can see a pattern ...

    okay, I'll try to provide a crash_log with debug on.


    one question: should I run the newest nightly or leave it with the yesterday's one ?


    - update -

    crashlog with yesterdays nightly: http://ix.io/2NEN


    last line from dmesg:

    [ 254.928231] VideoPlayer[933]: segfault at 50 ip 00007f808ac9d2fa sp 00007f7ff27f2580 error 4 in libva.so.2.1000.0[7f808ac98000+2a000]

    DigiBit R1, NUC8i3BE

    Edited 3 times, last by JoeAverage ().

  • Latest nightly is always preferred (in best case the issue is fixed).


    You can enable debug logging without overlay in advancedsettings.xml.

  • crash_log with LibreELEC-Generic.x86_64-9.80-nightly-20210128-fb96fe2:


    Ubuntu Pastebin

    - pastecrash didn't work (no link returned) -


    dmesg's last line:

    [ 4501.067910] VideoPlayer[938]: segfault at 7efdec003870 ip 00007efdec003870 sp 00007efdd57f0578 error 15


    TvHeadend service.log:

    Ubuntu Pastebin


    hint:

    on the above NUC connected to the same DigiBit with TvHeadend 4.3 running the same TV channel I also see in the web-IF Continuity error's, but so far (TV is running ~30 minutes) only 1.

    DigiBit R1, NUC8i3BE

    Edited 4 times, last by JoeAverage ().

  • - pastecrash didn't work (no link returned) -

    Unfortunately ix.io silently fail if the file is too long. Use

    Code
    pastecrash -c >~/crashlog_$(date -Iseconds).log

    and post the file manually.


    Regarding the VAAPI decoder errors you can try the older intel driver by creating:

    Code: /storage/.config/kodi.conf:
    MESA_LOADER_DRIVER_OVERRIDE=i965
    LIBVA_DRIVER_NAME=i965
  • nightly-20210129-f41aa8c with the above kodi.conf


    kodi.old.log:

    Ubuntu Pastebin


    why a kodi.old.log only ?


    well, the box didn't crash (no crash log generated).


    the running TV channel/broadcasting was just frozen.

    no black screen or crash.

    box was pingable, but no ssh into it anymore.


    hard reset needed to get it live again.

    DigiBit R1, NUC8i3BE

  • It's again the same ffmpeg error message:

    Code
    2021-01-30 22:48:57.397 T:938 ERROR <general>: ffmpeg[0x320be90X]: [h264] get_buffer() failed
    2021-01-30 22:48:57.397 T:938 ERROR <general>: ffmpeg[0x320be90X]: [h264] thread_get_buffer() failed
    2021-01-30 22:48:57.397 T:938 ERROR <general>: ffmpeg[0x320be90X]: [h264] decode_slice_header error
    2021-01-30 22:48:57.397 T:938 ERROR <general>: ffmpeg[0x320be90X]: [h264] no frame!

    I have no idea which component fails on the broken video stream. You can try to open a kodi issue on github.