MyGica T230A

  • Hi,

    I bought the MyGica T230A tuner. I didn't know there would be a problem with the letter A.

    When I connected it to rpi with libreelec, dmesg showed something like this:


    [ 262.006051] usb 1-1.1: new high-speed USB device number 4 using xhci_hcd

    [ 262.097416] usb 1-1.1: New USB device found, idVendor=0572, idProduct=689a, bcdDevice= 8.00

    [ 262.097433] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3

    [ 262.097448] usb 1-1.1: Product: USB Stick

    [ 262.097462] usb 1-1.1: Manufacturer: Gen

    [ 262.097475] usb 1-1.1: SerialNumber: 2017.12.09


    This tuner has entries in the "inf" file of the windows driver identical to the T230C v2 :


    %TC68A_DVB.DeviceDesc% = TC68A_DVB, USB\VID_0572&PID_C68A

    %TC68A_DVB.DeviceDesc% = TC68A_DVB, USB\VID_0572&PID_689A


    I patched the files: dvb-usb-ids.h, dvbsky.c and built a new image libreelec.


    After running, dmesg shows now:


    [ 262.006051] usb 1-1.1: new high-speed USB device number 4 using xhci_hcd

    [ 262.097416] usb 1-1.1: New USB device found, idVendor=0572, idProduct=689a, bcdDevice= 8.00

    [ 262.097433] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3

    [ 262.097448] usb 1-1.1: Product: USB Stick

    [ 262.097462] usb 1-1.1: Manufacturer: Gen

    [ 262.097475] usb 1-1.1: SerialNumber: 2017.12.09

    [ 262.402693] usb 1-1.1: dvb_usb_v2: found a 'MyGica Mini DVB-(T/T2/C) USB Stick T230A' in warm state

    [ 262.402961] usb 1-1.1: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer

    [ 262.403000] dvbdev: DVB: registering new adapter (MyGica Mini DVB-(T/T2/C) USB Stick T230A)

    [ 262.403012] usb 1-1.1: media controller created

    [ 262.404228] dvbdev: dvb_create_media_entity: media entity 'dvb-demux' registered.

    [ 262.479360] si2168 13-0064: probe failed = -121

    [ 262.479383] si2168: probe of 13-0064 failed with error -121

    [ 262.481522] usbcore: registered new interface driver dvb_usb_dvbsky


    What could that mean?

    Is there a problem with the firmware?

    Can it be fixed somehow?


    Edit:

    Tested on the devel version:


    LibreELEC (community): devel-20201214210405-8a6ca28 (RPi4.arm)

    LibreELEC:~ # uname -a

    Linux LibreELEC 5.9.10 #1 SMP Mon Dec 14 21:20:14 UTC 2020 armv7l GNU/Linux

    LibreELEC:~ #

    Edited once, last by secam7 ().

  • This is not the MyGica T230 or C or C v2 .

    I wrote about MyGica T230A witch idVendor=0572, idProduct=689a

  • This is not the MyGica T230 or C or C v2 .

    I wrote about MyGica T230A witch idVendor=0572, idProduct=689a

    In fact it is T230C2 as you can see for instance here: DVB-T USB Devices - LinuxTVWiki

    Although the same device ID does not always mean it's the same hardware inside (Astrometa for example), I would say MyGica is not so bad regarding this matter..

    Again, there's no need of urgent patching, this tuner works fine on latest LE versions.

    In LE 9.80 nightly, which I am currently using, there are only kernel drivers. Although it's not yet 100% rock stable and it may depend on which USB port is used (2.0 or 3.0), overall it works quite fine.

    In LE 9.2.6 official it was also working fine, as far as I can remember, at least with CrazyCat drivers.


    Edit: Ahh, the idProduct=689a is really different... :-( A fake or a quite new product???

    I see that Geniatech does not offer any Linux drivers but you may perhaps try to contact the Support or visit a forum ( Get Support from the MyGica official website ). So far I did not find any mention regarding to T230A under Linux. Maybe it will be necessary to grab the firmware from Windows driver, it also depends on HW difference from previous T230x sticks so more changes in driver sources could be a must...

    Edited 12 times, last by ghtester ().

  • Any succes progress on this stick? I got one too and wanted to use with libreelec on a raspberry pi. But i got the same problem als you. it is really frustrating

  • I just got an response from the seller with this link: media_build_u18.04.2_ker4.18_lib_201030.tar with his small note, download and install it.


    I didn't got it to work jet. but i wanted to let you guys know. And maybe some of you got lucky.


    Edit: he is also send me an install guide. CompilingTunersDriverForLinux_v1.2


    I have tried that, on my pi with ubuntu and an old laptop x86 ubuntu but I still run in to the same error for both of them...

    Edited once, last by Pascaltje ().

  • I just got an response from the seller with this link: media_build_u18.04.2_ker4.18_lib_201030.tar with his small note, download and install it.

    I not found any support for USB\VID_0572&PID_689A

    dvb-usb\cxusb contain support for some new geniatech products:

    USB\VID_0572&PID_C68A - T230C V2 (Si2141+Si2168D60)

    USB\VID_1F4D&PID_A681 - ATSC/CQAM USB Stick (mxl603+mn88436)

    USB\VID_0572&PID_A682 - ATSC/CQAM Dual USB Stick (mxl692)

    USB\VID_0572&PID_2886 - T232 DVB-T/T2/C Dual USB Stick (cxd2858)

    USB\VID_1F4D&PID_692F - ATSC/CQAM USB Stick (mxl692)

    si2183, cxd2858, mxl692, rs6000 frontend drivers without full sources,just precompile x86_64 libs.

  • Hello I have Rasperry Pi 4 and have this problem too.

    Firstly I tried patch dvb-usb-ids.h, dvbsky.c like in first post but same result My dmesg shows:

    si2168 13-0064: probe failed = -19

    So secondly I tried build modules from files above and tried to patch t230a as t230.. its look like old drivers when t230series was in cxusb but now is in dvbsky drivers. Also here I have error... Here is dmesg:

    [ 144.590948] usb 1-1.4: new high-speed USB device number 4 using xhci_hcd

    [ 144.722148] usb 1-1.4: New USB device found, idVendor=0572, idProduct=689a, bcdDevice= 8.00

    [ 144.722157] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3

    [ 144.722163] usb 1-1.4: Product: USB Stick

    [ 144.722168] usb 1-1.4: Manufacturer: Gen

    [ 144.722173] usb 1-1.4: SerialNumber: 2017.12.09

    [ 144.777039] mc: Linux media interface: v0.10

    [ 144.796334] dvb-usb: found a 'Mygica T230 DVB-T/T2/C' in warm state.

    [ 144.796581] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.

    [ 144.798866] dvbdev: DVB: registering new adapter (Mygica T230 DVB-T/T2/C)

    [ 144.798885] usb 1-1.4: media controller created

    [ 144.799818] dvbdev: dvb_create_media_entity: media entity 'dvb-demux' registered.

    [ 145.061870] DVB: Unable to find symbol si2183_attach()

    [ 145.061881] dvb-usb: no frontend was attached by 'Mygica T230 DVB-T/T2/C'

    [ 145.062079] dvb-usb: Mygica T230 DVB-T/T2/C successfully initialized and connected.

    [ 145.062191] usbcore: registered new interface driver dvb_usb_cxusb


    Now I am trying to resolve error of probing with stock raspberry kernel and I found error when I print chip vesrion in file si2168.c:

    si2168 11-0064: unknown chip version Si2159-\x88\xd0P


    So I think that T230A using same chip (2168-60) like T230C2 but there is problem with IO reading, But I am not sure about it.

    Edited 2 times, last by pego149: add chip version ().

  • Finally MyGica T230A working on linux (Raspberry Pi 4). Here is edited function in dvbsky.c which makes gpio write:

    Also I made like here: 34770c6.

  • Do I come to ask for your help? can you please tell where the error is?

    smp important: How to add new MyGica T230A? · Issue #224 · tbsdtv/linux_media · GitHub

    patches: 8ec77749b81a70c8616e39be4a0e2e0a5a9eb165.patch

    I know you will certainly have a direction, I tried to include this patch in the construction of the chewitt and I get errors related to: drivers / media / usb / dvb-usb-v2 / dvbsky.c

    include / media / dvb-usb-ids.h

    I just edited the patch for amlogic-t230c.patch.

    I directed to: projects / Amlogic / linux / patches.

    It is useless knowledge if not shared the world.

    Edited once, last by erbas ().

  • https://www.dropbox.com/s/yu90…x-mygica-t230a.patch?dl=1


    Edit: I updated my patch, please re-download

    As always friend you surprise! fast and efficient.

    Speechless.


    smp Just one more doubt?

    Can this patch be used in the 4.9 kernel?


    heliobara Back to Brazil! you need to test this construction.

    It is useless knowledge if not shared the world.

    Edited 3 times, last by erbas: Merged a post created by erbas into this post. ().

  • You mean 4.9 in CE? It will probably not apply to 4.9, a new patch will be needed.

    I understand.

    Perhaps cdu13a can help with that!

    It is useless knowledge if not shared the world.

    Edited once, last by erbas ().

  • https://www.dropbox.com/s/yu90…x-mygica-t230a.patch?dl=1


    Edit: I updated my patch, please re-download