No sound VIA HDMI cable from my Pi 4 to my TV

  • I have no sound coming from my Pi to TV via HDMI... I have gone over the sound menu in detail.. made sure that pass through is checked... what am I missing, can someone please HELP????


    Kody:(:(:(:(:(:(:(:(:(:(:(:(:(

  • Spelling our application name correctly would be a good start.

    And adding thirteen smilies isn't really helping.


    So... Connecting a Rpi4 to a TV directly, why do you need passthrough?

  • I have a similar problem of no HD audio playing through my Rpi4 on Kodi 18.9 w/ LibreElec.9.2.6 attached to a soundbar/TV combo. I recently hooked up a Samsung Dolby Atmos 7.1.4 soundbar to a Samsung 4K 2160 QLED90 UHD TV using a 4K Hdmi (e-arc to TV-arc) cable and I get no sound from the Rpi4. The RPi is connected to the tv via hdmi 1 input. I do get sound from the embedded Samsung TV apps and also from Chromecast on a different HDMI 2 input. I tried it with passthrough turned on the RPi and with no passthrough. Still no sound at all. I do the same hook up with no cable, but use a Bluetooth wireless connection from the soundbar to the TV, and I at least get sound but not full HD Dolby ATMOS.


    I recently learned the Rpi4 4K Video and HD audio are still a work in progress. I read test builds had progressed to full Dolby Atmos HD audio but not concurrent 4K 2160 video some months ago (mid 2020).


    Where is this software development currently and when will these updates (audio and video) potentially make it into stable public release Libreelec builds?

    Edited 2 times, last by ssmith1936 ().

  • I have no sound coming from my Pi to TV via HDMI... I have gone over the sound menu in detail.. made sure that pass through is checked... what am I missing, can someone please HELP???

    HDMI is connected to the port nearest the power connector?