RSS Feeds still OpenELEC

  • Hi, Yesterday I 'upgraded' from OpenELEC 6.0.3 to LibreELEC 7.0 on my RPi2. The update went smooth and everything works as expected.
    There is one thing: When I switch on 'Show RSS' is still shows OpenELEC feeds (OE 7.0 rc 2, OE 7.0 rc1 etc.), not LibreELEC.
    how can I solve this? (without switching RSS feeds off)


    Thanks!


    Jako

  • At some point in the past you editted the RSS feed via Kodi GUI and this copied the embedded /usr/share/kodi/userdata/RssFeeds.xml that contained a reference to OE's RSS feed to the userdata location of /storage/.kodi/userdata/RssFeeds.xml. As we don't forcibly check/edit userdata files during the update process the reference to the OE feed persists. If you check the embedded file location when running LE you will that LE does not publish an equivalent feed; because we don't have a feed and in LE builds the default is RSS disabled. You can solve the problem by editing the file :)

  • Thanks! I edited Rssfeeds.xml and removed feeds.openelec.tv/news
    I added libreelec.tv/feed to the file, but that does not seem to be working, or are you joking Grimson?

    Edited once, last by jako ().

  • For some reason I cant add this feed feed into feedreader (3.14). It keeps "loading". Anyone know where is the catch? I would like to have LibreELEC feed :)

    2x VIM3L, 3x X96 Air P3, 6x C2; 6x RPi2; 3x Win7 Kodi + vPeter's mariaDB plugin as Library DB


  • For some reason I cant add this feed feed into feedreader (3.14). It keeps "loading". Anyone know where is the catch? I would like to have LibreELEC feed


    thanks, added in kodi: add libreelec.tv RSS feed by lrusak · Pull Request #300 · LibreELEC/LibreELEC.tv · GitHub and backport of #300 by lrusak · Pull Request #302 · LibreELEC/LibreELEC.tv · GitHub


    For existing users they will have to remove their RSS feeds in order for them to be updated.

    Code
    1. rm /storage/.kodi/userdata/RssFeeds.xml

  • I added libreelec.tv/feed to the file, but that does not seem to be working, or are you joking Grimson?


    It works fine here, in LibreELEC and as a dynamic bookmark in Firefox.

  • Sorry Grimson, I made a typo in the feed . Now that it has the right link, feed, it works perfecty.
    Thanks!

    Edited once, last by jako ().