Adguard Issies with DHCP on Pi4

  • I think I am loosing my mind. I installed adguard in a docker container from linuxserver.io based on threads here. Now I can't find any of those references yet the docker container sitll exists, etc etc. Anyway. Adblocking works fine but I am having problem with DHCP. I am sure it is a docker port issue but I cannot figure it out and I think there are bugs that happen when selecting that because after selecting dhcp, the container never works again. Sniffing traffic it basically kills the container on reboot so i have to wipe it, reinstall the backup container and then restore the config file. Anyway. my issue is when activating dhcp inside of adguard....which works fine for blocking up to this point, it selects an ip address of 172.XXX.XXX which I imagine is the docker container address and gives an error that static ip is not set for the pi....even though it is. It tells me to configure a file I cant remember (i think like dhcpdns.conf or something) which doesnt exist on the pi) and when I then try and ignore that, when the pi reboots, no connection is made. In the addon configuration it says to do dhcp to open 67 and 68 but everyway I tried to do that failed and redirection failed too. Basically i think behind the scenes when the image tries to configure the container for dhcp, it kills whatever worked before and therefor kills dns access too. I tried lots of docker pages to try and figure it out myself but I either dont understand enough docker stuff or whatever that I can't make it work.

    I saw that someone else said just use Adguard DNS, but that is woefully bad compared to using the adguard home for a ton of reasons. So while that might be the rookie solution, Adguard works great except for me not being able to get dhcp to work, Logs dont tell me much so far, so every suggestion or help I am open for and i will gladly provide whatever anyone needs to help troubleshoot.

  • I honestly don't recommend running dhcp in a docker container, let alone on libreelec. Your dhcp should really be on a dedicated device like a router or pfsense.


    I use adguardhome as just a dns server for ad blocking, which is what it does best.


    With regards to the 172.x.x.x address, your correct that is an internal docker network ip. But, all the ports that you define in the addon settings should be mapped at the libreelec ip, so you need to use the libreelec lan ip and the ports you mapped to access adguardhome.


    For instance if you map port 53 for dns, on another device, you'd use "libreelec-lan-ip:53" as the adguardhome dns address