Wetek Play, LibreElec 9.0 and CVBS

  • Hello to everyone! :) I've a Wetek Play with LE 9.0 on it and I'm still using it with satisfaction. Now I needed to move it to an ancient tv set without HDMI and I wanted to take advantage of the CVBS output. The problem is it doesn't work! :(

    I've made a lot of research on the subject and it seems that the support for analog video has been dropped because it causes issues with HDMI. According to this thread:

    8.95.1 on WeTek play: Video calibration not persistent

    it seems that on LE9 Beta (which I coulnd't find a download link for) CVBS output should work just creating the "disp_cap" file in the userdata directory with the content of "576cvbs". I've found elsewhere that I could add another line with "480cvbs" on top of it and I've added it too. It isn't the case for me unfortunately: no CVBS output at all. Then I've found this thread:

    OpenELEC 6.0, Wetek Play: No support for 480cvbs/i/p and 576cvbs/i/p modes in Kodi · Issue #4502 · OpenELEC/OpenELEC.tv · GitHub

    I know it's for OpenElec and not LE but, given that it references disp_cap too, I've thought that maybe the approach behind could be the same, maybe linked to some Amlogic guidelines, I don't know.

    I've tried both with fallback_cap and override_cap to no avail. I presume all of this confirms that CVBS support is no longer present like suggested elsewhere. All of this seems confirmed by the fact that if I issue the command:

    cat /sys/class/amhdmitx/amhdmitx0/disp_cap

    no CVBS modes are listed. What's even worse is that now I can't get HDMI to work again, no output at all and I'm blind. LE boots fine and I can control it by the remote (just to power off, nothing more than that) and by ssh but, in spite of the fact that I've put everything back at the state it was at the beginning, no video, on HDMI neither.

    I've deleted every added file from userdata folder and also checked guisettings.xml and there I've found a strange thing: references to a 720x480 video mode which I've tried to remove but it keeps reappearing (though I stop kodi beforehand issuing "systemctl stop kodi") and I fear this could be an explanation (maybe that video mode isn't supported by HDMI output).

    Just to tell everything, I've checked the AV cables pinouts (I know it's a mess with Wetek Play and RPi's using different pinouts for example) and I'm using the right cable so the problem doesn't reside there.

    Two questions then... How to build LE9 (I don't want to revert back to older versions because I use some addons which aren't compatible with older versions) with CVBS support? I don't mind breaking HDMI, given that I wouldn't be using it anymore. Otherwise, I have already found a LE7 image which seems to have CVBS support here:

    The CVBS output is not fonctionnal

    The second one is how to temporarily restore at least a working HDMI output given that it's clear I'm missing something. I've also tried to put the 'stock' disp_cap from the aforementioned folder in the userdata one, still to no avail.

    Thanks in advance to everyone! :)

  • -=guybrush=-

    Unfortunately, the problem is twofold. The first problem is that the CVBS output was disabled 5 years ago, because it causes problems with HDMI: projects/WeTek_Play: Remove support for CVBS output, because it cause… · OpenELEC/OpenELEC.tv@ffe3936 · GitHub

    The second problem is that the analog audio output is also not working.

    So, in the first approach, the simplest solution might be to get an HDMI-Composite or an HDMI-SCART converter if you would not use the HDMI output for anything else. Fortunately, these adapters are available cheaply from China, but due to different TV standards (PAL/NTSC/SECAM), you need to find carefully a compatible converter for your analog TV.

    I also use one of my boxes with an adapter on a Full HD monitor, although it’s an HDMI-VGA, that also has a D/A for audio with a 3.5mm stereo jack connector.

  • dtech

    Yes, I already know all of that from my research but my hope was that given, still based on my research, that someone has built older versions (LE7 for instance) with CVBS support, it was possible to do the same with newer ones so to have a let's say 9.0.2-CVBS. I would go for the adapter though it isn't solving the problem but just going round it.

  • I've bought an adapter online but it would get a month or so to arrive so in the meantime I'll try to solve the problem instead of going round it. I've already talked about older LE version with working CVBS for the Wetek Play. Here they are:

    LE 7.0

    LE 8.2.5

    For the latter, it is necessary to rebuild the package like described in the readme, just issuing

    cat LibreELEC-WeTek_Play.arm-8.2.5cvbs.img.xz-part* > LibreELEC-WeTek_Play.arm-8.2.5cvbs.img.xz

    while for the both of them the update process is the same as always. As already explained, older versions aren't fine for me so I wanted to apply dtech's teachings...

    Here (another of the findings with my research) I've found a patch which seems to be what I'm looking for and I wanted to apply it to build a 9.0.2-CVBS. Here is what I've done so far:

    git clone https://github.com/LibreELEC/LibreELEC.tv.git -b 9.0.2

    and in the projects folder I've found what I expected, an encouraging WeTek_Play folder so I was planning to build everything just issuing

    DISTRO=LibreELEC PROJECT=WeTek_Play ARCH=arm make image -j8

    as dtech has teached me. The problem is that I thought what I had downloaded by git were the sources but by a very quick look I couldn't find any. I'm still missing something but I don't give up. As soon as I would have a bit more time, I would go on and post here the results.

    According to the last comment in the thread linked above, it could well be that CVBS support has been re-enabled and I just need to build everything up again with no modifications: it would be my first try though I still want to understand how to successfully apply that patch.

    Edited once, last by -=guybrush=- (October 15, 2020 at 10:14 AM).

  • I found an LE-8.2.5 firmware that supports the CVBS output:

    libreELEC-CVBS-binaries/LibreELEC-WeTek_Play.arm-8.2.5cvbs at master · rgenoud/libreELEC-CVBS-binaries · GitHub

    If possible, try it on an SD card, and if it works, the patches will need to be integrated into version 9.0.2.

    However, the analog audio output will probably not work with this either.

    My fault. I haven't noticed your reply and in my last post I've relinked the same. Thanks but I had already found that a long ago and it didn't suit me because I use some add-ons which don't work with it. I've linked it this morning (along with the rest) just to summarize my findings, just in case they could be of help for someone.

    I understand your point though and I would make a try with it.

  • I have news which put virtually an end to the thread. I've tried to use the 8.2.5-CVBS img in dual boot on an SD card (as done previously BUT when there was the stock WeTek firmware installed on the NAND, not LE) but it didn't work: it just didn't give me the option to boot from SD as I was expecting instead (and it should have happened). I've then tried to install it directly on the NAND but it didn't install neither.

    I've got the error described here and applying the workaround suggested in the same thread at post #6 I was able to install it. The only advice is that the /flash partition is mounted readonly so to apply the workaround it is necessary to remount it rw.

    I've edited disp_cap in the userdata directory accordingly but still no output on CVBS. Then I've started to think I needed to rule out an issue with the output so I've reinstalled the stock firmware and CVBS doesn't work with it either. The cable I've used works perfectly fine with my WeTek Core with stock firmware and even with LE but only for the boot spash screen so this rules out issues with the cable but I've also tested it with a multimeter with success, just to be absolutely sure.

    I've then opened my Play and tested the same cable while connected to the CVBS output: there is connection so it isn't a physical problem with the connector itself but I'm starting to think that my Play has something wrong with the circuitry handling that output and maybe with the actions I've taken and described in my first post CVBS could have worked even with 9.0.2 (my idea is linked with the latest sentence in the thread pointed out in one of my previous posts).

    It is almost impossible to scour a Play these days and I can't do anything more than what I've already done under the current conditions so, without the help of someone else who owns a Play with a working CVBS output, we're at the end. That's a pity. I would use it with the adapter I've already bought but this is only a workaround and many questions remain unanswered unfortunately and so they would remain given that I don't see (and I understand the reasons for that) much interest around this topic. :(