Can't change System name

  • Hello - new forum member looking for some guidance:

    I have been using LibreELEC for a few months, since my old OpenElec (hope I'm allowed to say that) Pi 2 system's SD card died. I've been a Kodi user on X86 since early XBMC days.

    I have two LibreELEC installs running now, one on the old Pi 2 and one on a Pi 4. Very happy with them, and thank you to the developers for such a nice system.

    I have been trying to get a system running on a Pi 3 model B and everything is working except I can't change the system name. I go into Settings>LibreELEC>System>System Name and whatever I type in there, it reverts back to LibreELEC. I seem to remember I had some reluctance with both the other installs, but managed to change the name after a couple of attemps, but this one refuses point blank. I have tried another fresh install on a brand new SanDisk 16GB microSD card but no luck.

    Apologies if this is a common newbie thing - I looked for similar threads and only found one and that had no real answer.

    What am I doing wrong?

  • There are two locations for that... (yeah, I know). Don't ask, just change them both.

    One is in the Kodi menu settings, and the other is in the LibreELEC Settings add-on.

    The same goes for the workgroup name.

  • Thanks for your reply - by 'Kodi menu settings' do you mean via Add-ons from the main menu? I've tried that, it still reverts to LibreElec.

  • No, in Kodi via Settings/Services/General/System/Device Name.

    The workgroup name can be changed via Settings/Services/SMB client/General.

  • Well, that's confusing...

    the skin that comes with LE doesn't have a Services option in Settings- but I remembered that the old standard Confluence does. Changing to that,the Device Name in Services is entirely different to the one in the Librelec settings - "Kodi". Now I understand your "yeah, I know" :

    Anyway, I changed it there and it worked, and I'm seeing the name I want in my home network uPnP devices. So thank you for your help.

  • the skin that comes with LE doesn't have a Services option in Settings

    You probably need to change the menu level to 'Advanced' or 'Expert' to get Kodi's full Estuary menus.