IPTV Simple Client CURL issue

  • Hey guys,

    I’m trying to update my librelec (rpi 3) 8.2.5 to 9.0 or 9.2.

    I’m using IPTV Simple Client to watch tv from a m3u playlist, but it doesn’t work from the 9.0 version.

    As I have realized, from v9.0, Kodi is using Curl for sending requests to the iptv server, and my kodi log confirms this, I see Curl errors, like “server is not responding”.

    I saw this thread, the guy solved it by setting the user agent, but it didn’t help me.

    [SOLVED] On LibreELEC-RPi2.arm-9.0-Milhouse-201806xxx PVR SIMPLE CLIENT Not Work

    i will copy my kodi log here very soon :)

    Do you have any idea how could I solve this ? Or can you recommend another pvr client which is not using curl ? But I guess this is a system-wide feature...


  • Same problem...

    2020-10-15 22:10:52.190 T:1807721344 ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 403

    2020-10-15 22:10:52.190 T:1807721344 ERROR: CCurlFile::Open failed with code 403 for http://aaaaa.com/bbb:

    2020-10-15 22:10:52.190 T:1807721344 ERROR: Open - failed to open source <http://aaaaa.com/bbb>

    2020-10-15 22:10:52.190 T:1807721344 ERROR: AddOnLog: PVR IPTV Simple Client: Unable to load playlist file http://aaaaa.com/bbb': file is missing or empty.

    It suddenly stoped working...

    The same URL works fine on GSE IPTV on iPhone/Android, the channels URLs works normally on VLC...

    Only LibreElec / IPTV Simple Client stoped working :(

    Running on RPI3 + LibreElec 9.2.4 and also in a RPI1 + LibreElec 9.2.4. Both stoped working.

    Even the weather ADDON stoped working - even with all internet connection tests working fine.

    Is there any update on LibreElec that could cause general curl/connectivity problems?

    So weird...


  • The HTTP 403 Is a HTTP status code meaning access to the requested resource is forbidden for some reason. The server understood the request, but will not fulfill it due to client-related issues.

    Check http://aaaaa.com/bbb with a browser. This might provide information about your issue.

    The server might not like the user-agent used by IPTV simple.


  • The URL aaaa.com/bbbb was just a bogus to not reveal the real URL :-)

    The real URL works fine on browser or any other http client...

    The User-Agent was faked due to a test... it doesn't work when I keep it default or try to simulate another one.

  • I understood that the url was obfuscated.

    Nevertheless, the 403 code means that the server forbids your client.

    Do you use a VPN on your RPis and not on your other systems?


  • Workaround:

    -Install a nightly version of libreelec with Kodi 19

    -ssh to libreelec

    -create a file called "advancedsettings.xml" in /storage/.kodi/userdata folder

    cd /storage/.kodi/userdata
    touch advancedsettings.xml
    nano advancedsettings.xml

    -add this code to the advancedsettings.xml file


    -save and exit nano (CTRL+X)



    The nightly version i´m using is very buggy in Rpi 1b..wireless not working correctly and everytime i reboot libreelec requires to install again simple iptv addon.

    But got my iptv working again

  • Hi All, this is fixed for me now without any update to libreelec or my iptv provider... I guess cloudflare made a change at their end. Anyone else experiencing the same?