Help - Error upgrading to 9.x

  • Hello.

    I'm having an issue with versions +9. Any 9.x gives me this error.

    And it didn't happen with 8.x or 7.x.


    My PC has an Athlon 3500+ and Radeon R9 270X.


    What can I do to install it?


  • Try following the advice and add noapic to the kernel command line.


    For easiest testing start modifying /syslinux.cfg on the 9.2.3 install stick and boot from it.

  • To the APPEND lines, i.e. for installer:


    Code
    1. APPEND boot=UUID=... installer quiet systemd.debug_shell vga=current noapic

    Edit: according to your picture you already tried kernel 4.19.36

  • Better now.

    I could install it, but when it should reboot, I get the same mistake as the picture.

    This, with Kernel 5.


    With Kernel 4, the installation starts, but I end up with no video during installation.

    Thanks for help

    Edited 3 times, last by robdanmar ().

  • You have to add the noapic parameter to the installed system too:


    1. Boot the install stick again.
    2. On the first installer dialog press <Alt>-F3 to get the console screen.
    3. Type blkid to list the partitions. Memorize your system partition device (most likely /dev/sda1).
    4. mkdir /tmp/mnt;mount <Your Device> /tmp/mnt
    5. nano /tmp/mnt/syslinux.cfg, add noapic. Save with <Control>-X
    6. reboot
  • Sorry for being unclear. That is the syslinux boot screen. Continue to the next with:

    Code
    1. MAIN MENU
    2. Welcome to LibreELEC installation tool!
    3. [...]
  • sorry, its control +alt +F3 or alt +f3?

    thanks for your help!!!

    in libreelec 8.2.5 control+alt+F3 works (console)

    in libreelec 9.2.3 control+alt+del, alt+f3 or control+F3 does not work. The console does not open when I do that

    What commands would be the new ones? The ones that DO work

    its a bug?

    Edited once, last by robdanmar ().

  • No idea. Can be an issue with the "radeon" kernel driver of your Radeon R9 270X Southern Islands card.


    Just use the 8.2.5 installer stick to change the parameter for the installed 9.2.3 system.


    Edit: Beside of this control+alt+F3 should work in both X and text console and alt+F3 in text console only.