Network configuration

  • this is the setup I'm trying to create:


    DHCP server running on eth0. AP is connected to the eth0, and any clients connected to it get the IP from my DHCP server.

    onboard wifi will not be used, but for now I use it to have ssh connection to the board while I'm configuring it.


    I installed pihole. I first tried PiHole LE add-on, but that did not work. I get the add-on in the list, can enter configuration menu, but nothing seems to work. docker ps does not show anything running.

    So I removed and installed the pi-hole docker manually. That worked, I can access the WebGUI, enable DHCP server etc. However, the DHCP itself is not working. I connect my laptop with WireShark running, I can see it sending out DHCP requests, but nothing comes back. Looking into /storage/.cache/connman/ethernet_dca63240d968_cable/settings I see that the Ethernet is configured to DHCP, which it should not be, since I have the DHCP server running there. The port should have static IP, the one I provided in the PiHole Web GUI (right?).


    I used

    Code
    1. connmanctl config ethernet_dca63240d968_cable --ipv4 manual 192.168.76.1 255.255.255.0 192.168.76.1

    to change the IP to manual. Now when I connect anything on the ethernet, ifconfig shows correct information, but DHCP server is still not working, and clients don't get anything assigned. Query log under the PIHole WebGUI continues to remain empty.

    I'm attaching the pihole configurations pages from the web gui, and the output of the ifconfig for eth0. Hopefully someone would be able to point me in the right direction. Thank you!

  • LE is inentionally a "client" OS with some super-limited server capabilities and docker support targets running basic apps that complement our client fucntions. If you want a server device, you're running the wrong distro.

  • Thank you for your answer. All I need from the libreElec is h.265 playback @ 4K resolution, which works great by the way. Does LE has anything related to 4K playback that is not present in other distros?

  • Ok I tried a regular R-Pi. Even though I was able to quickly setup the networking the way I want, I can't get video to play on a 4K display. VLC simply crashes. (Actually tried it already before. One of the reasons I switched to LE). Kodi starts, but refuses to play video (through .strm file).

    I'll try again with LE and use plain dnsmasq instead of Pi-Hole. Do you think it will not work as well?

  • I've no idea what a "regular" RPi is but if you add facts like model number to the question; the Zero thru 3B+ models do not support 4K and the 4B does support it. And "no log = no problem" .. because we suck at blind guessing what user issues are.

  • Sorry for troubling you!

    I was using the same HW, Raspberry PI 4B. 4K playback only works under Libreelec. Under Raspbian I can't get either VLC or Kodi to play 4K stream on 4K monitor. I know, it is not your problem :)

    I was able to run DHCP server (dnsmasq) on LE server in the docker in the end. It was docker configuration error (missing ports publishing). I'm sure Pi-Hole was not working for the same reason.

    Thank you for the great work you do on LE!