RPi4 testbuild with HD audio passtrhough (Atmos etc)

  • Hi,


    I installed LE 10.0.2 in my RPi4 and audio passthrogh is working very well, including losseless encoding. The only thing not working is Atmos. Atmos on DD+ tracks is not working also.

    Have I to do on my RPi some special configuration to get it? RPi4 is connencted to a Yamaha RX-V6A. Thx!


  • Yes. E-AC3, Dolby TrueHD and DTS HD MA are enabled and I’m getting DD+, DTHD and DTS HD MA, I can see it on the AVR display, but on tracks with Atmos the Atmos metadata is stripped. They are played without Atmos.

  • Sorry, no idea then. Since you get Dolby True HD flagged the RPi/kodi side looks fine.


    Might be worth checking your AVR settings, maybe something is set up wrong (or there's some firmware bug in the AVR).


    so long,


    Hias

  • How Atmos detection is performed? AVR setup is 5.1.2.

    I do not see any special settings for Atmos in it. However, thank you for your help.

  • What a funny thing! I simply connected RPi to hdmi 1 of AVR instead of hdmi 2 and Atmos is working too! At least the first 3 hdmi inputs should be equal……

    Ok.. I’m sorry for the lost time. Thank you for help! :)

  • Oh, that's really weird.


    Thanks a lot for reporting back and telling us about the solution, and glad you got it working!


    so long,


    Hias

  • Just a quick update. I discovered It’s not the physical hdmi port to create the issue but how it is configured. If you enable on it a DSP Program the Atmos will not work, you need to put it in Straight mode to get Atmos. So, on Yamaha AVR, set it to Straight mode!