LibreELEC (Leia) 9.2.3

  • Analog audio output is working fine here on RPi3B+ with LE 9.2.3 and current 9.2.4 development builds.


    so long,


    Hias

  • HiassofT:


    I'm having an Openssl compilation issue, regarding your postings in the forum you are expert in this topic, so may I ask for your help, please?


    Coming from the "Windows world", I'm a Linux NOOB, so please have mercy with me :-)


    I'm trying to Implement a driver in the current version 9.2.3 of LibreELEC for RaspberryPi 4, there are detailed instructions for this at Implementing xpadneo drivers for future releases ? , however, the process of compiling is terminated because of the following error message:

    "NOTE: if in doubt, on Unix-ish system use './config'.

    FAILURE: scripts/build openssl:host during configure_host (package.mk)

    **************** FAILED COMMAND ******************

    ./Configure $PKG_CONFIGURE_OPTS_HOST $PKG_CONFIGURE_OPTS_SHARED linux-${MACHINE_HARDWARE_NAME} $CFLAGS $LDFLAGS"


    Using a RaspberryPi with "RaspberryPi OS Buster" as my Linux platform (I've tried it under Gentoo Linux. too), I've followed exactly the step-by-step instructions given by basilean in his thread, but unfortunately, after having entered "PROJECT=RPi DEVICE=RPi4 ARCH=arm scripts/build xpadneo" for building the package, I waited until the prompt appeared in the end again, however, I didn't get a file named "hid-xpadneo.ko".


    I'm assuming this is because of the compilation error related to the openssl issue, so I've tried modifying the makeinstall_target() function in packages/security/openssl/package.mk the way it is described in a posting at Openssl compilation issue , but the compilation error still persists.


    I've even contacted basilean and vpeter directly, however, they seem not be visiting this forum anymore. :-(


    Could you please have a look at it and tell me what I'm doing wrong with the compiling?


    I'm thankful for any hint!

  • This is the news and announcement section, not the fix my problems section. You'll have better luck if you open a thread in the appropriate area and include a complete error log.