NUC8, Thunderbolt 3 and HD audio passthrough

  • Does anyone have any recommendations for a Thunderbolt 3 (USB C) -> HDMI cable/adaptor that supports HD audio passthrough in Linux/Libreelec?

    For a while I couldn't understand why I was only able to get HD audio out of the NUC's thunderbolt 3 port within Windows until I stumbled upon this thread: Intel NUC8i3BEH Audio Issue

    Unfortunately the product link in that thread no longer work, does anyone have any others they know that work?

    I have tried Anker USB C -> HDMI (Only works in windows), and recently tried the Club 3D adapator which annoyingly also doesn't work (I don't know if I should be reaching out to them to see if theres a firmware update?).

    Surprising, I randomly tried my iPad's USB C to HDMI adapator and that kind of worked, but the audio had slight interference.


    Potentially this might work?

    Limited Display Modes/No Sound
    Amazon.com: Cable Matters USB C to HDMI Adapter (USB-C to HDMI Adapter) Supporting 4K 60Hz in Black - Thunderbolt 3 Port Compatible for MacBook Pro, Dell XPS 13, 15 and More: Computers & Accessories

    Edited once, last by PlatypusW ().

  • Is anybody able to explain why this seems to be so flaky?


    I tried starting and stopping a dts-hd file 20 times to see how often I got passthrough sound, results:


    Club adaptor: 0%
    Anker cable: 5%
    Apple adaptor: 40%


    Why is it like this? Drivers? EDID?


    I somehow don’t think getting a specific adaptor is going to help is it?


    Is this an intel problem? It works 100% of the time with all adaptors in windows.


    Is it even worth me trying a different build, e.g a Milhouse build?

  • I was wondering if anyone was able to reliably get HD Audio passthrough using the thunderbolt 3 port on a NUC (8,9,10) running libreelec?


    myccpay

    Edited once, last by Nieves200 ().

  • I was wondering if anyone was able to reliably get HD Audio passthrough using the thunderbolt 3 port on a NUC (8,9,10) running libreelec?

    Thanks for the reply, am I missing something obvious there? My NUC is definitely 8th gen and is listed as having:


    Thunderbolt™ 3 USB-C port providing DisplayPort 1.2 or USB 3.1 gen 2


    I would understand if it shouldn’t work and in fact never worked. That would be great actually.
    But what actually happens is that HD Audio works, but only about 5% of the time. The only thing I have to do is stop and start the video again and it might just decide to work.


    It’s enough that it annoyingly doesn’t just flat out ‘not work’ but doesn’t work enough that it’s actually usable.


    At this point, I’d love to just know why if nothing else. As I said, am I missing something obvious?