Raspberry PI 4 no support for 4k video play and resolution

  • Hello,


    this is my first problem with libreelec, so I do not know which infos I should supply. I will try my best and if something is missing then I will add it.

    I bought a new Samsung TV RU7179 4k HDR and I wanted to use the Raspberry PI 4 which I used before on my 1080p TV.


    I was not able to select a resolution greater than 1920*1080 60hz. There is no option for 2160p 30hz or 2160p 60hz.


    I thought it is a bug of an old system which was not updated for a long time, so I used the libreelec tool to install the system fresh for my RPi4. The current version was 9.2.1. The problem persists.


    I have tried several reboots and in the config the setting "hdmi_enable_4kp60=1". But this did not change anything. I also tried to change the HDMI cables and the ports on the TV. This did not work either, only 1080p can be selected.

    Also it is not possible to play 4k video files. A loading animation is shown for a short time and immediately after that the PI restarts. Here I tried 3 different 4k files. All files are .mkv with 2160p resolution and coded in x265.


    I just want a simple small system that I can play 4k files from a USB stick without problems, because DTS is not natively supported on Samsung TV.


    I hope someone can help me with this problem.


    Thank you very much in advance!

  • hey,


    it seems my TV does not have this setting. I can not find anything under picture or external device management.

    I will check later if the manual can help me with this setting. Could it be, that my tv does not support this setting?