SSH timed out

  • I bought my raspberry pi 3 today but fail to establish the ssh connection :(

    Neither with my windows laptop (putty) nor with macOS in Terminal.

    Ssh is enabled of course and the ip adress is 100% correct.

  • Unless you enabled "disable password auth" and connect but fail to login (as the setting disabled password auth) .. there is either a firewall active that is blocking traffic or you don't have the right IP address or the device is not on the network correctly. Otherwise SSH works, and has been working in the distro for years without issues.

  • I did everything you said, even added ssh to the port forwarding on my router, still can’t connect unfortunately.

  • I'm not familiar with Fritzbox routers and my German is out of practice, but that page looks like it is for port-mapping. Did you put the device in a "DMZ" on the router? If yes, you will probably need to access via the WAN IP address not LAN.

  • There are rumors that option -o IPQoS=throughput is required in some ssh client/server combinations. Just try.

  • I'm not familiar with Fritzbox routers and my German is out of practice, but that page looks like it is for port-mapping. Did you put the device in a "DMZ" on the router? If yes, you will probably need to access via the WAN IP address not LAN.

    ok damn. That was it probably. Somehow I have to use 192.168.0.28 instead of 192.168.188.32. Don’t know why but thank you very much !

  • ok damn. That was it probably. Somehow I have to use 192.168.0.28 instead of 192.168.188.32. Don’t know why but thank you very much !

    you should read the service pages from AVM or your manuals regarding IP-Adresses of "Gast-(W)LAN".

    Further I guess it's unnessary to setup "Portfreigaben".

    ssh should do OOB.

    on my 7590 I don't need to setup Portfreigaben to reach my LE via ssh.



    - but it's some years ago that I was running a 7390 -

    DigiBit R1, NUC8i3BE