use a remote controler like wiimote with retroArch

  • Hi,

    I probably miss a keypoint because after reading carefully wiki HOW-TO:Configure_controllers and a bunches of threads, I've never ever been able to play a single game on Kodi with retroArch ;(

    I can bind my wiimote and navigate throug Kodi : it works like a charm. But when I want to open a game via Retroarch, the game open, but I'm not able to send a single command to try to play.


    I was expecting, after some releases, to see a controller profiles called "Wiimote", or to see a hint how to create such a profile, but I failed until now.

    I've tried do configure the NES profile to play some NES game, but I'm not able to set a single buttons : the countdown goes down from 4 to 0 and no button is mapped.

    I've tried to use the add-on "Keymap" and achive to map any button of my weemote to some navigation controls, and it works with kodi navigation, but it doesn't help for interacting with retroarch (did I miss a section in keyma?).

    Each time a game is running, if I press "A" on my wiimote, I see the pop-up with options to resume, change control, change video size, ... but if kodi can receive orders from my wiimote, why Retroarch is not reacting?

    I'll never give up and still hope playing my old dream "Bionic Comando" on NES emulation.

    Any direction on what to check on hints would be greatly appreciated :D

    Thank's for paying some attention and wish you a nice day :)


  • All I can find in the RA config files regarding Wii is this :

    "Wii U GameCube Adapter Port 1"

    Do you have adaptor?

  • First of all, there's a difference between "RetroArch" and "RetroPlayer", the first being a standalone project, and the second is the code name for a "player core" in kodi that plays games. I assume you mean the second? RetroArch is a separate process and thus wouldn't support any controller configuration from within Kodi.

    Second, can you upload a debug log that shows you playing a game and pressing a button that doesn't work? I only see 14 lines in the log you posted. Given that Kodi's controller system is so massive, a debug log will give me a sense of where in the system your presses are getting dropped.

  • I have the same issue as the OP.

    I am running LE 9.2 on a NUC8i3. I have a wired logitech gamepad that works well, and I can use a Nintendo Wii U Pro controller via Bluetooth just fine.

    I can pair a wiimote via bluetooth and it acts fine in Kodi - I can control the menu and playback alright. In Retroarch it shows up as a controller, but none of the buttons have any effect. Not in the menu, or in any cores. (I have tried several Mame and Nintendo cores).

    My next step is to replicate the issue while viewing the debug log to analyze it in detail. Since wiimotes are rather common this surprises me somewhat.

  • it appears eventlircd grabs the wiimote input and doesn't play nice with rettroarch. I had the same problem and fixed it by starting RetroArch, sshing into LibreElec and killing eventlircd and the wiimote immediately started working in RetroArch now

    Edit - Nevermind this seems to break multiple inputs

    killall eventlircd
  • I have an x96 s905x 2GB / 16GB box. I bought a usb sensor and a bluetooth stick kodi to navigate nicely during the wii motion plus. But when I start the retroarch the nes duck hunt game doesn't respond to anything. Libreelec system. I tried to shoot what you wrote on ssh: killall eventlircd, but neither the kodi nor the retroarch became a result in the kodi after that it could not work.