Video not playing on nightly Lafrite build

  • Hello,

    completely new to this and I got a LaFrite as a christmas gift so I thought I'd try to put LibreELEC on it.

    I grabbed the nightly 20200324_lafrite image and loaded it up.

    I everything seems to work ok up until I try to play a video then it seems to not want to play it.

    Wanted to make sure it wasnt the video so I repurposed one of my rpi's with the latest stable for rpi1 and that seems to play fine.

    Wanted to see if anyone had any thoughts or advice on this as I do not have much low level OS building exp.


    videoInfoScreenCap

    uploadedLog

    attached is the mediaInfo of just one of the videos I was trying to play

    Let me know if any other info would be useful, would be happy to share.

    Thank you for your time/effort.

    Files

    • mediaInfo.txt

      (5.21 kB, downloaded 17 times, last: )

    Edited once, last by cman122887 ().

  • Video playback is still "work in progress" on the mainline kernel but MPEG4 video should be software decoded anyway which should negate that.


    Please share a Kodi debug log file (current one is not debug), and upload a sample of the file somewhere so I can download and see first hand. You can remove the file after it's been downloaded.

  • Hey chewitt,


    Thank you for the info, that is good to know that its still WIP.

    I think this log should have debug enabled, sorry about that: http://ix.io/2fOR

    When running it again to grab the debug log, the video actually got a couple frames in then froze permanently.


    link_to_video

    That is the video I am testing.

    Let me know if you need anything else.

    Thanks

  • It played fine on an S905 device (WeTek Hub) for me. I will dig LaFrite out of a box and test S805X after work later, but I wouldn't expect there to be any fundamental differences.

  • Oh interesting. Maybe it's an issue with my USB then.

    I'll try with a different USB and create the image using the libre USB creator instead of Ubuntu startup disk creator.


    Update (a bit of a long one):

    Tried a older usb using libre usb creator. Loaded only my test video, and it worked!

    Loaded a bunch of other videos, then the problem came back.

    Removed all the videos I just added, working again. (side note, that made me think i could go back to my other usb by removing all videos but my test one, this did not work)

    Started loading in videos one by one (thinking a specific file was the problem), and it seems like this workflow kept LE working the whole time!

    side note on how I'm loading videos - pluggin in the usb to my laptop and copying files into the STORAGE->videos area


    Since this little project is only for my son to watch his small library of videos, this will work for me :)

    I am curious though why my copying over a bunch of videos would make it falter in playing while copying over one file to then launch LE to test it would have it work.

    Edited once, last by cman122887 ().

  • FWIW .. I was playing the file from an NAS (SMB) device in the network using the low-spec on-board WiFi of the Hub. I'm not aware of any issues with USB read/write performance on Amlogic SoC's but I also never/rarely use local media with any low-power ARM devices; not because they're inherently bad, but because I swap between 20+ devices on a regular basis so everything's in a central place in the network to make that easier.