Kodi start black until HDMI is re-connected

  • I have a fresh 9.2.1 installation on a RPi 3 Model B, with an HDMI connection to a Dell U2414H.

    When booting, all goes well (splash screen and all) but as soon as Kodi is started the screen goes black will remain so until the HDMI cable is physically disconnected and reconnected. While it's black, HDMI signal seems OK but the image is black and blank.


    Tried everything I could - config.txt tweaks, hard coded resolution in Kodi, tvservice manipulations, etc. It seems like nothing I do makes any difference and the ONLY way to get the display back once black is to physically reconnect.


    Any ideas on how to solve, things to check?

    Thanks!

  • Try this settings at config.txt:

    Code
    hdmi_ignore_edid=0xa5000080
    hdmi_force_hotplug=1

    Flexin' vinyl, jammin' break beats. 8)

  • I tried those settings, it's still the same - screen goes black when Kodi is up, until I physically reconnect the HDMI.


    Update: after reconnecting the HDMI and everything is fine, restarting Kodi will get back to a black screen. So basically the issue is HDMI needs to be connected only *after* Kodi is up.

    Edited once, last by yossigo ().

  • So basically the issue is HDMI needs to be connected only *after* Kodi is up.

    Put tvservice -p into autostart.sh.

    If this is not successful, post your current config.txt.

    Flexin' vinyl, jammin' break beats. 8)

    Edited once, last by Da Flex ().

  • Running tvservice -p manually at any point makes no difference. If I run tvservice -o the signal stops, and tvservice -p brings it back but it's still black.

    The config.txt is the default with only two added lines:


    Code
    hdmi_ignore_edid=0xa5000080
    hdmi_force_hotplug=1


    Although dropping this and practically any other change to config.txt did not make a difference.

  • Thanks for testing the autostart.sh line.

    The config.txt is the default with only two added lines:


    Code
    hdmi_ignore_edid=0xa5000080
    hdmi_force_hotplug=1

    Just to be sure you tried the right config.txt options, add this lines to the above:

    Code
    framebuffer_width=1280
    framebuffer_height=720
    hdmi_group=1
    hdmi_mode=4

    It will start your RPi at 720p / 60Hz, fitting for your monitor specs and RPi speed.

    Flexin' vinyl, jammin' break beats. 8)

    Edited once, last by Da Flex ().