[8.2.3.1] LibreELEC 8.0 for S805

  • First post updated with a special build to test Kodi PR10887 which aims to improve audio/video sync.
    If you encounter playback issues, please enable Debug log and Component logging only for Video component (disable all other components including ffmpeg) and provide Kodi log.
    2016-11-22-PR10887


    Source code: 2016-11-22-krypton-PR10887


    I have to admit I've incorrectly placed PR10887 patch in the latest test build and it did not apply... apologies for all who dedicated their time for testing. I will issue a new build when more testing is needed.

    Edited once, last by kszaq ().

  • Hi,


    I've upgraded my second box to LE 7.90 alpha and noticed some lags when both boxes are on while using Yatse (android app) as a remote. The problem is that both boxes uses the same mac address 00:01:23:CD:EE:AF.
    This bug was in LE 7.0 and was fixed by kszaq in this post LibreELEC.


    The workaround with a udev-rule to change the mac does not help with my box.

    Edited once, last by dharry ().


  • No prob....will need to redo box with old version or will next one be updateable to this one?


  • OP updated with Kodi 17 beta 6. :D


    Does this have PR10887 or any other fixes for the stuttering playback? The github link in OP doesn't work, and I don't see a new tag on github.

  • GitHub updated. This build doesn't have PR10887 as it doesn't work well with automatic framerate turned on. This build has "pure" Kodi 17 beta 6 with 1 fix regarding playback for S805: aspect ratio tracking for H.264 streams.

    Edited once, last by kszaq ().


  • GitHub updated. This build doesn't have PR10887 as it doesn't work well with automatic framerate turned on. This build has "pure" Kodi 17 beta 6 with 1 fix regarding playback for S805: aspect ratio tracking for H.264 streams.


    Thank you for your awesome work. I still have bad stuttering on my 23.97fps movies (which are almost all of my approximately 800 movies), so I'll hold off on running it daily for now.


    I did notice an improvement with 50fps video playback on a TV with no 50hz support (60hz): On the current stable release, movies playback flawlessly when auto changing the refresh rate to match the 23.97fps, but my 50fps Planet Earth II and fights stutter (not quite as bad as movies on the alpha release though). On the alpha release, 50fps videos playback nearly perfectly at 60hz (probably what minimoe noticed with his formula 1 race).

  • Hello ppl and thank you again kszaq for your great work!
    I installed 7.90 on sd to my mk808b plus but cec is not working. On 7.0.2 works fine,any suggestion?



    Sent from my iPhone using Tapatalk

  • Arghh! Boot Loop (I'll try again)
    [hr]
    Both 2016-12-01 versions bootloop here :(
    Mind you v7.0.2.7 works great, so no problem :shy:

    Edited once, last by Poida ().

  • Even a clean install to SD won't work - just get a boot loop. :(
    Not game enough to try clean install to nand :dodgy:

    Edited once, last by Poida ().

  • Poida I think it's an issue of three dtbs I used for a single build. I'll change it for a next build. Don't try to install it to NAND, you'll get the same result.

  • Works very smooth on both my MK808b+ boxes ... thanks a lot kszaq


    Q: is there any benefit to move Libreelex to Internal Storage ?? ... I cant find guidance to move the install to internal! .. any advise is highly appreciated


  • Don't try to install it to NAND, you'll get the same result.


    Ok thanks