Networking LE with Winblows machines..

  • I am trying to get my network back up and running..

    I have 2 winblows workstations and the LibreElec all on the same network..

    I USED to be able to access it but now I can't..

    The two MS workstations see each other, but the LE Box can't see either and neither of the 2 can see the LE Box..

    I am in the LE via SSH, but it's been a LONG while since I played with linux..

    Could anyone give me some guidance to make sure all the network settings on the LE box are correct???

    Any help would be appreciated...

  • Wired or wireless network ?

    SMB, uPnP or NFS ?

    Version of Windows ?

    SMB no longer allows browsing your network

  • Thanx for the reply..

    Wired.. I am old school.. Like the reliability of a hardwire. :D

    Not sure.. Just thru the windows networking..

    Windows 10...

    Thanx again..

  • Take us through the steps you're using to add network shares using Libreelec

    Just hooked it up to the network and it was visible to the Windows 10 machines..

    That's what has me confused.. I didn't do anything to the LE machine.. It just worked after setup..

  • Apologies for the lack of follow up.. My daughter just got married on 29 Feb and just couldn't find a free second..

    I think I have discovered the reason why my connection failed..

    To give a little more detail...

    I have 3 computers at my house..




    STARFLEET is the WORKGROUP (seeing a pattern?? :D)

    HOLODECK is my video server that has 10TB worth of storage. All our TV shows and movies we have..

    ENTERPRISE and INTREPID are Windows 10 machines.. HOLODECK is running KODI on a LibreElec flavor of LINUX..

    It USED to be I could see and share files between HOLODECK, ENTERPRISE & INTREPID with no problems..

    NOW, for some reason, ENTERPRISE & INTREPID are linked but can't see HOLODECK and HOLODECK can't see either of the other 2..

    I usually advise people to think back to what happened that might have changed.. Unfortunately, this is too far back in the past to have a clue...

    I came across this tidbit of info:


    The fall “Creators Update” for Windows 10 removes SMB1 client/server support and NAS devices now ship with configuration that only supports SMB2/3 – causing problems because all versions of Kodi before 17.4 can only make SMB1 connections. This release includes changes that allow the Kodi SMB client and our embedded Samba server to work with SMB2/3 connections; improving SMB security and performance. However, it is a disruptive change:

    The Kodi SMB client sometimes fails to negotiate SMB3 with old Samba versions. There is a new option in Kodi Settings > Services > SMB client > that allows SMB2 or SMB1 connections to be forced for compatibility with legacy SMB servers.

    The embedded Samba server now defaults to minimum SMB2 and maximum SMB3 and the LibreELEC Settings add-on allows the supported SMB protocol versions to be changed for compatibility with legacy clients. It also allows configuration of the WORKGROUP name.

    Samba 3.x /storage/.config/samba.conf configurations must be updated to use the new Samba 4.x template (samba.conf.sample) as some Samba 3.x configuration is incompatible. The embedded Samba server may fail to start until this is done. If the reason for older changes was workgroup name please delete the file and use the new in-GUI configuration method.

    Browsing SMB shares via “Windows network browsing” in Kodi requires the browser service on the SMB server. This SMB1 service is removed from Win10 in the creators update and there is no equivalent for SMB2/3 versions of the SMB protocol. When Kodi makes SMB2+ connections (which is now our default) Kodi network browsing to add sources will not work. Windows SMB shares can still be added using the full server/share path. It is still possible to browse non-Windows Samba/NAS devices that advertise SMB shares via ZeroConf (aka Bonjour/Avahi).

    Connection failures to anonymous and guest shares are solved by creating a new local machine (not Microsoft ID) user and strong password for Kodi to use on the server, then assigning appropriate read or read-write permissions to the shares Kodi will access.

    LibreELEC (Krypton) v8.1.1 BETA – LibreELEC

    In the immortal words of Tom Cruise...

    "Now, I don't know what all that means, but it sounds pretty bad.."

    Am I hosed?? No recourse???

    Thanx again and I'll stick with it.. At least until 5 Apr :D

  • You can no longer "browse" the network from Libreelec using SMB. You must manually setup Windows 10 network shares. There are many threads here describing exactly how to do this. I was one of the first to have this problem way back in November 2017 with the release of LE (Krypton) 8.2.0

    Maybe someone else can link one of the threads with instructions on setting up SMB Shares from Windows 10

  • Awesome.. Thanx for the point in the right direction... It's difficult to keep my video server stocked if I can't access from my workstations..

    So I need to set up a Win 10 Network Share on the Kodi box..

    I'll search for that..

    Thanx again....

  • Blue

    This look familiar??

    I hope this helps. I had the same problem with Windows SMB Shares and got help in this forum.

    Accessing Windows Shares using SMB

    1. Your Windows shares must have a login and password assigned.

    2. The new Windows samba (SMB) DOES NOT allow browsing to the path, so you must type the actual path.

    Example: smb://192.168.x.x/movies (use your own IP and folder name)

    You can also add the path to your shares by clicking BROWSE and selecting "add network path" and filling out the form shown:

    Protocol: Windows Network (SMB)

    Server Name: 192.168.x.x (use your own IP address)

    Shared Folder: use your folder's name here (ex: movies)

    Username: your Windows username

    Password: your Windows password

    Any update to this???

  • Also, can you give me some hints on how to do it thru the libreelec console?? Saves me the trouble of having to use the remote on the GUI of Kodi..

    If it's not too much of a hassle, I mean...

    Thanx again..

  • Also, can you give me some hints on how to do it thru the libreelec console?? Saves me the trouble of having to use the remote on the GUI of Kodi..

    If it's not too much of a hassle, I mean...

    Thanx again..

    I'm not sure what you're asking. Just click "Add xxxxx" in any category (videos, music, pictures) and follow the directions to add the proper Windows Shares.

  • It just makes it easier to follow online directions... My workstation is on the other side of the house from the TV/KODI box.. :D

    No matter.. I can hang...

    Interesting thing this morning..

    I had played with the SMB settings within KODI and set up a path to the workgroup, STARFLEET..

    When I powered on the PC this morning and checked, I saw this (see attached pic)

    So, now the LibreElec box can see ENTERPRISE and INTREPID...

    But I still can't see HOLODECK from ENTERPRISE or INTREPID...

    Does this mean I have to update er... (in keeping with the theme) the "sensors" on ENTERPRISE and INTREPID??

  • Curiouser and curiouser

    I tried to create a direct link to a HOLODECK drive via windows File Manager..

    Got the attached error message...

    So, it seems to me that the config still has to continue on the HOLODECK side..


    Oh Oh Oh... Progress..


    Not as a computer, but as a media device...

    So, I am getting closer...

  • To access your Libreelec machine (HOLODECK) from your Windows PC's, open Window's File Manager and enter: \\ (holodeck's IP address)

    • Official Post

    I am in the LE via SSH, but it's been a LONG while since I played with linux..

    Here's a different approach:

    - create a Ubuntu 18.04+ (Server) bootable USB stick.

    - install it on a 2nd USB stick (4-8GB should be fine)

    - boot the Ubuntu (Server) USB stick

    - add your local disk(s) via /etc/fstab
    - install NFS kernel server: sudo apt install nfs-kernel-server

    - mount your disk(s) for the NFS server, do this via ' sudo nano /etc/exports' and add the drives

    - restarting stuff:
    - sudo mount -a
    - sudo service nfs-kernel-server restart

    Done in less than an hour. :)

    Rescrape your media collection in a new video database and have no more SMB hassles.

  • The first time I tried it, I got a windows error box...

    Subsequent times, it tries to open a Chrome Tab and says can't connect via the web...

    Back slash \\ will access your network using Windows File Manager

    Forward slash // will activate your browser

    Your LE device must be turned on to be accessed from a networked windows machine

  • I don't think I am in a position to re-do my entire KODI setup.. :D

    Thanx for the suggestion, though..