RPI4 low fps video playback despite minimal cpu load

  • Hi


    so i have LE running on a 4gb Rpi4 connected to a LG C9 TV running Hyperion service in the background for the diy-Ambilight. My media is stored on a USB3 WD 3.5" external hard drive.


    I solved my initial problem of LE just flatout crashing after a couple of seconds by switching system resolution from 4k to 1080p60. It will however still crash as soon as i play any video without adjusting framerates after a couple of seconds of playback (apparently it's a problem with hyperion+60hz+rpi4). Not a big deal since most content i watch is 23.9fps anyway. So i've enabled adjust refresh rate change to 'always' and finally videos do play... well, sort of...


    The problem is that playback is really choppy and checking the OSD status reveals that instead of the desired 23.9fps the playback framerate floats around the 10fps mark. What's weird is that the cpu at the same time sits at a comfy <20% load. And i am talking 1080p h.264 content, so nothing that should give the rpi4 any trouble..



    i have tried disabling hardware acceleration in the playback menu but that just bumps up the cpu load. The 10fps problem persists.Checking the logs also did not reveal anything out of the ordinary.


    i thought that it might have to do with the fact that the rpi4 is running an emby server and that playback on the same machine might cause some trouble but even when i play the video via the kodi file explorer from its physical location i get the same problem.


    any ideas/help would be much appreciated.

    Cheers!

  • hey so i did some further testing , alas no success


    - disabled hyperion completely

    - messed around with audio settings (according to another thread there was something about audio passthrough which -in any case- i am not even using)

    - whitelisted a bunch of resolutions

    - forced the gui to 23.9hz and disabled/enabled "adjust refresh rate"

    - forced gui to 60hz (etc...) and disabled (=crash) / enabled "adjust refresh rate"

    - played around w deinterlace


    but still ~10fps playback. interestingly if the scene is relatively still fps will be at the desired 23-ish mark but as soon as there is movement it will plummit back to 10fps (while temps are at 50°c and load <15%)


    i am kind of running out of ideas tbh.. so if anyone has an idea please share!



    :edit

    -stopped/disabled all docker containers

    -tried the other HDMI-out at the rpi4 (no sound all of a sudden...)


    no success...10fps. It might also be worth mentioning that the GUI too feels pretty sluggish when navigating through menus

    Edited 3 times, last by phob08 ().

  • fixed it... well , sort of...


    got so frustrated that i just started from scratch with a new sd-card


    installed LE, Emby-Server, Hyperion.


    now it seems to work fine. except for any 4k material (non-hdr) which will cause the hdmi signal to just die... but i suppose that's another issue

  • so the pi is working in combination with hyperion now?

  • this whole thread is outdated. i don't know what it was but the mistake was obviously on my end...



    RPI4 + Hyperion works just fine


    except for 4k HDR material. Read the other threads for workarounds for more specific issues (i.e. 1080p 50hz, et al)

  • So you could watch 1080/50 with hyperion without any problems? And your kodi self screen resolution is? 4k or full hd?

  • yes. 1080/50 works just fine. read the last two pages of the other thread for instructions.


    GUI limit is 1080p, Kodi resolution 1080p / 4k both work