DVB-C Tuner not being recognized

  • Hi.


    I have bought an Astrometa DVB-T2 Tuner (Astrometa DVB-T2 - LinuxTVWiki). It is most likely the 2018 revision, since I can see the following chips inside:

    • RLT2832P
    • D2837ER
    • R828D

    I'm using a Raspberry Pi 3 with LibreELEC (Leia) 9.2.0.


    I've connected my tuner, but on TvHeadend I'm only able to see the DVB-T tuner, as shown on image below:


    I tried looking at dmesg, but I was not able to see any references to the D2837ER chip: http://ix.io/26in


    After some online reading, I've seen some comments advising to try enabling DVB drivers from the latest kernel (media_build). So I did this change, like seen below:


    After reboot, TvheadEnd still doesn't show the DVB-C tuner. However there is some progress, since I can see refereneces to D2837ER by looking at dmesg: http://ix.io/26jh


    By looking at the table on Astrometa DVB-T2 - LinuxTVWiki, specifically at the 2018 revision, I can see that on the Supported line it states "most likely since 5.0". Also, on this post Astrometa DVB-T2 SONY cxd2837er not listed in TV Adapters the user seems to have the exact same issue and at the end he states: "SOLVED: upgraded to Kernel 5 and now is working".


    So for me this raises the following questions:

    • Do I really need the kernel 5 in order to use this tuner (since with the latest drivers it seems to, at least, be recognized and loaded)?
    • Will LibreElec be updated to use kernel 5 any time soon?
    • Will that kernel bump be available on Raspberry Pi 3 compatible images?

    Any clue is mostly welcomed.


    Thanks in advance!

  • try the "Drivers from latest Kernel"


    not sure if they work but you can easily try it (if not pls share a dmesg | paste)


    you can also try an recent milhouse build that come with 5.3 and pre Alpha of Kodi19

  • Hi CvH, thanks for your reply!


    Perhaps I explained myself poorly, but I already tried that ("Drivers from latest Kernel"). Here is the dmesg result: http://ix.io/26jh


    It detects the Sony chipset now, but doesn't show on Tvheadend still!


    Where can I find a milhouse build and how can I try it?


    Thanks

  • Big thanx to @nhmarujo .... your hint to use "DVB drivers from the latest kernel (media_build)" made my day. Seems the chipset Sony CXD2837ER is not supported in standard Kernel 4.19 driver modules of LibreELEC 9.2.1.


    All sources are somewhat mentioning that even people made it somehow working on Kernel 4.x after patching it (

    Auzeuner DVB-T2 (Astrometa 2018) driver update by kapitanf · Pull Request #567 · torvalds/linux · GitHub - patch probably coming from

    https://www.ebastlirna.cz/modu…=0&postorder=asc&start=15 ) - indicate that it is not stable/supported - only in Kernel 5.x.

    LibreELEC 10 is still in DEV and should have Kernel 5.x (I believe 5.4 - source LibreELEC - Wikipedia ) - and for that we have to still wait ...


    Steps to enable DVB-T2 and DVB-C for Auzeuner DVB-T2 (Astrometa 2018) with chipset Sony CXD2837ER:

    • platform LibreELEC 9.2.1 + Tvheadend 4.2 all on RPi 3 (image LibreELEC-RPi2.arm-9.2.1.img.gz)
    • I couldn't test the DVB-C - do not have cable - but I executed the TVHeadend DVB-C scan successfully (of course not finding any service)
    • my DVB-T2 scan in TVHeadend 4.2 with it's default Mutex definition for Czech Republic was successful and I finally found some DVB-T2 services (before that - scanning via RTL8233P chipset - I was finding only DVB-T services)

    Steps to make it happen:


    • Enable DVB drivers from the latest kernel (media_build) in LibreELEC Module Drivers Add-On and Reboot:


    • After Reboot you should see that /dev/dvb/adapterX/frontend1 exists (before that only frontend0 was there)
    • LibreELEC:~ # dmesg | grep -n DVB-T
      • 303:[ 9.226198] usb 1-1.2: dvb_usb_v2: found a 'Astrometa DVB-T2' in warm state
      • 308:[ 9.407100] dvbdev: DVB: registering new adapter (Astrometa DVB-T2)
      • 316:[ 9.463662] usb 1-1.2: DVB: registering adapter 0 frontend 0 (Realtek RTL2832 (DVB-T))...
      • 317:[ 9.463701] dvbdev: dvb_create_media_entity: media entity 'Realtek RTL2832 (DVB-T)' registered.
      • 318:[ 9.464161] usb 1-1.2: DVB: registering adapter 0 frontend 1 (Sony CXD2837ER DVB-T/T2/C demodulator)...
      • 319:[ 9.464186] dvbdev: dvb_create_media_entity: media entity 'Sony CXD2837ER DVB-T/T2/C demodulator' registered.
      • 328:[ 9.575091] rc rc0: Astrometa DVB-T2 as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/rc/rc0
      • 329:[ 9.575310] input: Astrometa DVB-T2 as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2/rc/rc0/input3
      • 332:[ 9.602958] usb 1-1.2: dvb_usb_v2: 'Astrometa DVB-T2' successfully initialized and connected
      • After that we can tune the DVB-T2 services successfully (TV Adapter in TVhedend's Configuration->DVB Inputs need to be disabled for t2scan to be able to lock the device):
        • LibreELEC:~ # t2scan -Y CZ -a /dev/dvb/adapter0/frontend1 -t 2
        • FREQ (42.00MHz ... 1002.00MHz)
        • Scanning 8MHz frequencies...
        • 474000 (CH21): (time: 00:00.220)
        • ...
        • (time: 05:48.036) dumping lists (71 services) Cool
    • Next important step - Disable in TVHeadend the RTL Chipset and keep enabled only Sony CX Chipset (both DVB-C and DVB-T are okay) - after reboot you will see 3 devices under the /dev/dvb/adapter0, after enabling any of those devices - all 3 devices are listed "green" in TVHeadend and can be used to scan DVB-T/T2/C - BUT after reboot (if you keep RTL Chipset enabled) - the TVHeadend start is way longer than usually and then it lists only the RTL device and none of the Sony CX devices.



    • Stability of the player - enable "Force old status" on both Sony CXD2837ER devices (DVB-C and DVB-T)
    • (I have no proof this flag really helps but I remember this flag being mentioned on other forums + I had few crashes while playing DVB-T2 service if this flag was not enabled)



    • One last thing - to have Video stream working in DVB-T2 - Czech Republic (the audio was working fine) - I had to disable OMXPLayer HW Acceleration. Interestingly with the DVB-T on RTL chip - this HW acceleration enabled was actually working fine:


    Edited once, last by calaba ().

  • I can test the tuner with a RPi3 and raspian buster, but it doesn't recognize well the tuner. The raspian buster uses the kernel 4.19. Then, I update the kernel to 5.3 using the command rpi-update (rpi-update - Raspberry Pi Documentation). The first time work perfect; however, after reboot only appears the DVB-T #0. The solution was unable the RTL chipset and enable again as Cabala (thank you!) explained.


    I'm using in Colombia with VLC media player in windows.