MP3 audio playback stutters/drop-outs with RPi4B/2GB

  • Hello,


    i have a Raspberry Pi 4/2GB with the latest stable release from LibreELEC.


    When I play MP3 audio files, I have regular dropouts - i.e. every few seconds there is a "stutter" in the music, or a drop-out.


    When I play flac, or even video files, I don't have this problem, it only occurs with MP3. I used to have an RPi2 with OSMC and had purchased the MP3 licenses there; there was no stuttering with the same files ...


    Does anyone know advice/help? Thanks!


    Eriol


    PS: What I am currently trying is to add the follwing line to /flash/cmdline.txt - but this unfortunately does not help ...


    Code
    sdhci-bcm2708.missing_status=0 sdhci-bcm2708.sync_after_dma=0


    This hint came from this forum. Maybe someone understand this line and can adapt this for LibreELEC?

  • Hello,


    this issue is still there. Playing mp3 files from my RPi4 with LibreELEC 9.2.1 has constant audio stutters. Playing video does not cause any issues at all, neither audio nor video stutters.


    Am I really the only one who has this issue? I have a clean LibreELEc installation ... An hints or help?


    Best regards

    Eriol

  • It may be a buffering problem on small files.

    Can be avoided by using kodi's file cache.


    Try adding a file:

    /storage/.kodi/userdata/advancedsettings.xml


    Containing

    Code
    <advancedsettings>
      <cache>
        <buffermode>1</buffermode>
        <memorysize>500000000</memorysize>
        <readfactor>10</readfactor>
      </cache>
    </advancedsettings>


    You can check kodi's wiki here:

    advancedsettings.xml - Official Kodi Wiki

    Edited once, last by grael ().

  • Without a logfile we're unable to help.


    So please provide one, then we can stop guessing ;)

  • grael, I had the same prob as EB and I thank you for your suggestion which did cure the stuttering :love:
    There was a downside though causing playlists to jump several songs after each play.

    I changed settings to ...
    <buffermode>4</buffermode>

    <memorysize>7000000</memorysize>

    <readfactor>4</readfactor>

    ... and this cured the playlist jumping too :thumbup: