pi4 - doesnt detect 1080i

  • So for some reason on a pi4 kodi isn't giving me the ability to set the display to 1080i. The display I'm using is really flaky and doesn't like any resolutions other than 480p or 1080i - if I set it to 720p the colours go all wrong (it seems to be a hardware issue with the display, I've tried everything with the pi's config.txt and nothing seems to make a difference)


    I tried setting

    hdmi_group=1<br>

    hdmi_mode=5<br>

    <br>

    The pi's bootscreen 'colour splash' thing shows perfectly, but as soon as libre boots it seems to go back to 720p and libre doesn't give me the option of 1080i<br>

    For some reason I haven't been able to determine setting hdmi_ignore_edid=0xa5000080 along with these stops libre from displaying anything at all (though the colour splash still works)

    <br>

    My old pi 1 B+ seems to see 1080i and uses it without issue...


    Is there a way for force a 1080i to show up, or forcibly change it


    Edit a Log file but I didn't have debuging turned on when I was testing this... if you need debugging on I'll have to run it tomorrow as I can't currently do anything with it...

    Edited once, last by mrsix: attach log ().

  • 1080i isn't a resolution it's a method of interpolation fields to reduce codec performance drag.

    From memory if your tv can only play 1080i it wont be able to handle the 1080p resolution. So set it to 720p.

    So for instance I have it set to 1080p resolution but when I play 4k the videos resoution is 4k but the user interface is 1080p.

    Also you might want to check kodi forums and maybe even open elec and raspbian ones on how to force resolution.

    STICKY: Setting up HDMI output when video output is wrong. - Page 19 - Raspberry Pi Forums

  • We have several threads where users want to force a display mode, which is not detected by LE. To my knowledge, there is no way.

    Flexin' vinyl, jammin' break beats.:thumbup:

  • 1080i is indeed a display mode which has little to do with codecs....


    The annoying thing here is the display's EDID does indeed report that it not only supports but prefers that mode:


    Code
    1. ibreELEC:~ # tvservice --modes cea
    2. Group CEA has 7 modes:
    3. mode 1: 640x480 @ 60Hz 4:3, clock:25MHz progressive
    4. mode 2: 720x480 @ 60Hz 4:3, clock:27MHz progressive
    5. mode 3: 720x480 @ 60Hz 16:9, clock:27MHz progressive
    6. mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive
    7. (prefer) mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced
    8. mode 6: 720x480 @ 60Hz 4:3, clock:27MHz x2 interlaced
    9. mode 7: 720x480 @ 60Hz 16:9, clock:27MHz x2 interlaced
    10. LibreELEC:~ #


    If I use tvservice -e "CEA 5" it switches the display mode and uses the mode perfectly.... but kodi is still at the 720p display resolution so it shows up in the top-left corner :/


    edit: even more interesting if I force mode 4 it displays the colours properly... something libre/kodi is doing differently in 720p mode is causing the display to be all green....

    Edited once, last by mrsix ().

  • Quote
    Code
    1. (prefer) mode 5: 1920x1080 @ 60Hz 16:9, clock:74MHz interlaced

    Then despite of your thread title, 1080i is detected.


    The unusual point, compared to other users, is that you have a coloring issue. Have you already tried a different HDMI cable? If you buy a new one, look for the "HDMI High Speed" or "HDMI High Speed Premium" standard.

    Flexin' vinyl, jammin' break beats.:thumbup:

    Edited once, last by Da Flex ().