PI4 9.1.501 4K Content playing in Left Corner

  • I am a long time Kodi user but just activated my first device on the LibreELEC platform.


    I am using a PI 4 2Gb attached directly to a Vizio V-series Display that is 3840x2160 native.


    For the most part things are going smoothly, but I am encountering an issue with 4K in general. Regardless of what I display, the TV always registers a 2160p signal. If I set the GUI to 1080p all content up to and including 1080p presents correctly. However, any change to 4K causes an issue.


    If I play a 4K file, the output displays only in the upper left corner of the display as if the PI4 is outputting a padded 1080 picture in a 2160 frame.


    I tried changing the GUI to 3840x2160 and then the GUI is only displayed in the top left corner.


    I have whitelisted all the 4K resolutions available, so, if my understanding is correct, the image should not be scaled by Kodi.


    Attached is a clean log that is a fresh reboot followed by an attempt to play a 4K file. I would greatly appreciate any input as I am currently at a loss. Thanks in advance.


    log-2019-09-18-05.06.49.zip


    Adding File Resolution 3840x1920 (Not a standard resolution in the white list)


    Ken




    Edit: It appears I was able to resolve the issue before the thread was approved. In case the solution helps others.


    I went back to check the config.txt file to ensure I had enabled 4K. Everything looked fine, but the "hdmi_enable_4kp60=1" entry was the last line in my file. I decided to move it up in the file, not expecting it to work, but after a reboot it did. Everything is acting as expected now.


    Thanks

    Edited 2 times, last by yeahman518: Resolved ().

  • Many thanks for your input to the forum.


    If possible could you post a screenshot of the error, to assist other users in deducing the problem. Tnx

  • Many thanks for your input to the forum.


    If possible could you post a screenshot of the error, to assist other users in deducing the problem. Tnx

    Unfortunately, I can't share any more details on a fix as it turns out the fix didn't stick.


    After modifying the config file yesterday, I cycled the PI a few times and everything still appeared to be resolved. This morning, I cycled the box again, and the issue has come back.


    I even tried to modify the config file again but this time there was no change.


    So, I am back to needing help if anyone has any ideas.


    Here is a fresh log file.

    log-2019-09-18-17.36.48.zip

  • OK


    I think I have the issue resolved. I an not sure which action corrected the issue so here's what I did in case it helps someone.


    1. I wiped everything and freshly installed LibreELEC.

    I don't think this was the key, but a fresh start allowed me to test as every addon was installed.

    2. I set LibreELEC to wait for the network for 15 seconds.

    Originally I had this at 10 seconds. Originally, the third status would fail on the splash screen. It looked benign as it was a waiting for network fail. However, it goes away set at 15 and I suspect it was messing with the startup of some addons.

    3. I installed Open VPN and did not install the NordVPN addon from the Nord repository.

    Nord's site recommends installing both. This time I just installed Open vpn and Nord is working fine. In fact, it is more stable now. I was getting some inconsistent results starting up. This could also have been influenced by item 2. But, less addons is simpler and it is working.


    At this point I have roughly a dozen bounces completed and everything is humming with solid 4K performance.


    I will wait to mark the thread as resolved until a few more days of stability have passed.

  • I've had the same issue after upgrading to beta1 from the alpha release. I'll get a picture later. I've a spare SD card too so will see if a clean install resolves it.

  • still good?




    I had the same issue creep up recently. I'm using the pi4 with a ks8000 Samsung. I installed the latest libreelec and everything was fine in 4k 30fps. my main issue was jerky playback so I've been troubleshooting that with different audio and video and frame rate adjustment settings. anyway yesterday I rebooted the pi and it was displaying in the top left corner when in 4k. changing to 1080p would resolve this. the only solution was a hard reset from the libreelec add-on options. no big deal but had to set up a few things again.




    all seems fine now but I've just reverted to 1080p now. it's the only thing offering smooth playback. and it's only smooth at 60fps. dunno why. my guess is 4k at 60fps would be smooth too. I guess that's my next test. when I edited the config file tho to include 4k60, the resulting 4k option would not display on my TV. so I'm guessing my tv doesn't support that. in any event, 1080p at 60fps with the better cpu of the pi4 and gbit lan and 4gb ram is still a nice upgrade. I always play my 4k over dlna through my TV anyway, which triggers the HDR mode of the tv. the pi4 doesn't have that support yet I don't think.




    I also want to try that wait for network solution you posted above. I dont have any VPN addons tho. I do run subtitles however and I know there's chatter about subtitles causing jerky playback. again, not in [email protected] for me. I'll have to do some more trouble shooting on that front too.