LibreELEC 9.2.X video judder and stuttering [renamed]

  • Kodi only accepts htsp

    The client is HTSP so that''s probably why.

    Nevertheless, pass is default and also used for recording.

    I have never struggled with stream settings as defaults worked. Now I tried to enable the Restart on error: option and disable the Switch to another service: option for both htsp and pass profiles to see if there's any change when the signal level drops...

    Possible bad (new) Haupagge tuner?

    Well, try the USB 2.0 port as well... USB 3.0 is not always the best choice for some devices. Also, the dual tuner stick is a bit power hungry. There's no extra power reserve on USB ports of RPi 4B, it also depends on your power supply. So you may try to use some USB hub with external power (or make a USB cable fork to bring a hard 5V to your USB tuner).

    My tuners sometimes hangs after switching to another channel but it's then visible in dmesg output and in this case USB port power off / on is necessary to make it working again (I suppose the reason is most likely the low power / long USB extension cord issue).

    Edited 4 times, last by ghtester ().

  • It's the WinTV Dual tuner, the 1595.


    Here's a web page I looked at.


    Hauppauge WinTV-dualHD - LinuxTVWiki


    I read this paragraph, checked my dmesg command output and confirmed it was set to bulk:

    Quote

    Setting Transfer Mode to bulk

    The stick supports two transfer modes: isochronous and bulk, whereas most revisions use the isochronous mode by default. This often leads to artifacts being shown in the video stream when both tuners are active (e.g. when a EPG scan is running in the background). This problem has been confirmed by many users of the VDR (German language, [Gelöst] WinTV dualHD - Moduloption um nur einen Tuner zu nutzen? - DVB-Karten - VDR Portal), but is very likely to occurr with other software as well. You can check the mode your stick is using with dmesg. When the stick is detected there is a line that reads "dvb set to isoc mode" when in isochronous mode, when bulk mode is active, an analogous message is shown. Currently there is no known way to change that mode using a linux command or passing options to the kernel module. The only way to change it is to use a free windows tool provided by the manufacturer Hauppauge: Hauppauge DE | Support FAQ Please install the windows driver for the stick first, because they need to be installed before running the tool. After changing the mode to "bulk" using this tool, please check the dmesg messages again and verify that it now states "dvb set to bulk mode".

    At this point I'm ready to buy another tuner that's known to work on the PI4 with Libreelec. Are there any tuners out there, single is fine if need be, that absolutely work out of the box with the current version on the Pi4?

  • Also make sure you have the latest USB firmware installed on your RPi 4B ( see RE: Is it possible already to set up a rpi4 with kernel 5.4? ). There're some updates regarding to isochronous transfers in past as well.


    And do not underestimate the power for your devices, it's really important.


    Regarding to another DVB-T2 sticks, I am using MyGica T230C, T230C2 and two Astrometa models with Sony & Panasonic demodulators.

    T230C / C2 is working best on latest LE versions, with Astrometa I had more struggling but currently it's working also fine for me (and the hardware has some advantages, like SDR functionality and the driver supports all IR protocols).

    The problem is - you usually don't know what exactly you'll receive when ordering on eBay / Aliexpress. The stick may look the same but inside the HW is different. But I have ordered MyGica tuners through Aliexpress from original store and negotiated the specific version before.

    • Official Post

    Another standard point to check: Make sure your PSU has enough wattage, because the tuner stick probably grabs a lot of it.


    PS: If you have a notebook, test your tuner stick with a standard Linux like Ubuntu. Then you can be sure that your notebook will provide enough wattage for the tuner stick. You don't even have to install Linux, because you can run a "Live" version directly from USB stick or DVD.

  • If single tuner DVB-T/T2 is fine then have a look at the RPi TV Hat Buy a Raspberry Pi TV HAT – Raspberry Pi


    so long,


    Hias

    Since that won't work in North America, not a great suggestion. Got to be NTSC is my understanding.


    DVB-T2 not for North America I don't think.


    Another standard point to check: Make sure your PSU has enough wattage, because the tuner stick probably grabs a lot of it.

    You've been patient and helpful, but it sounds like this forum is out of ideas. It's a standard PI4 power supply. Pretty sad that a reasonably tech savvy guy like me can't get live TV on the newest PI variant.


    I think I'm going to try and run

    Ubuntu and then Kodi on top of that. Certainly can't be more frustrating. But thank you.

    Edited 2 times, last by harry_fine: Merged a post created by harry_fine into this post. ().

  • ATSC, DTMB, DVB-T/DVB-T2, and ISDB-T - Digital Terrestrial Television (DTT)


    NTSC perhaps not = analog = obsolete


    DVB-T2 not for North America I don't think.

    All the sticks I mentioned also supports DVB-T and Astrometa also supports analog TV / SDR but of course I don't know what's the status in your location.

    Edit: Ahh, just looked at your tuner so it's ATSC. See the comparison: 201908_dvb_and_atsc3_compared_infographic_a5.pdf

    So you can't realy use any tuners we mentioned here...

    It looks you already gave it up so the last advice - I would try to disable one tuner and check if there's any change...

    Edited 5 times, last by ghtester ().

    • Official Post

    Before we do that, post what you already have. The official PSU has 3A. Is that yours?


    PS: I don't want to make you buy more useless stuff. It's possible that NO RPi PSU provides the wattage for your dual tuner. In that case it's better to buy a single tuner instead (see the suggestion from HiassofT ).

  • The easiest thing would be to connect the tuner via an externally powered USB hub.


    I can't comment on your specific tuner, would guess though that when using the official power supply it should work fine, if it's the only thing you connected to the USB ports (RPis have limit on overall power draw on USB ports).


    From my personal experience with a Xbox USB tuner I can say it works fine, but if I also connect a bus-powered HDD it fails miserably - total USB power consumption is too large and that makes the tuner completely drop off the USB bus (USB disconnect messages in dmesg).


    so long,


    Hias

  • I have the official, 3A 15w. And really, am I like a pioneer here? Am I the only person with a dual tuner? I've asked several times in this thread for a north american ATSC tuner that works for sure out of the box with a PI4 under Libreelec but so far no luck.

  • If it's original 15W adapter, it should be OK otherwise you would see a yellow lightning flashing in right top screen corner.

    But the question is if the USB stick is not at the USB port's power limit... As recommended earlier, consider trying an USB hub with external power supply adapter (even USB 2.0 should be enough), it's always good to have it even if it won't fix this issue.

    Before that, try to disable one tuner and check if it won't help.

  • If you go WAY back in this thread, I described how I did an identical install on an Intel NUC with an I5 preprocessor. Same version of LE (but generic intel), same USB tuner, same HDMI v2. cable, same antenna, and same result. Audio quality (AQ) would drop to zero after a few seconds streaming live TV, and the streaming would stop for maybe 30 seconds.


    This is either a defective Haupaggue tuner, or it's a bug in Libreelec, perhaps the driver for the tuner. If someone can tell me how the powerful intel box with lots of processing power and current could display the same symptoms, I'm all ears.

  • Hauppauge WinTV-dualHD - LinuxTVWiki


    Both tuners on Model 01590 device and Model 01595 device are supported since Kernel 4.17 (see commit kernel/git/stable/linux.git - Linux kernel stable tree).


    Linux is a multiuser, multitask operating system.

    Windows is a single user, multitask operating system.

    The Windows timings are not as critical as Linux.

    Try the tuner in a Windows machine.

    If the same results, the issue could be signal strength.


    References:


    Hauppauge WinTV Dual Tuner


    Hauppauge WinTV-dualHD - LinuxTVWiki

    Silicon Labs Si2157 - LinuxTVWiki

    Si2157-short-268718.pdf


    The Silicon Labs Si2157 is a hybrid DVB-T, DVB-T2, DVB-C, ATSC, DTMB and QAM Tuner.

    Regional operation is dependent on the software supplied by Hauppauge.


    Hauppauge UK | WinTV-dualHD Product Description


    Digital Video Broadcasting (DVB)

    Digital Video Broadcasting - Wikipedia


    Hauppauge | WinTV-dualHD Dual TV Tuner


    Advanced Television Systems Committee (ATSC)

    ATSC standards - Wikipedia

  • So basically, after hours of searching online, and hours of helpful people here, I cannot find one ATSC USB tuner that will work with the PI4 and Libreelec. Pretty sad state of affairs. Not one!


    Reading here, there are caveats and drivers required for almost everything, and just because it works under Linux doesn't mean it will work under Libreelec.

    Linux TV USV tuners


    Surely there is someone out there who has a working solution with a configuration that is reasonably similar.

    The Silicon Labs is not a usb tuner stick. And the 1590/1595 is the one I have that I've been struggling with despite the amazing help I've been getting for two days.

    So what I'm looking for is one other stick, single or dual tuner, that is known to just work with a PI4 and Libreelec.