9.1.002 *definitely* has some kind of scanning issue, debug log attached

  • I have reported stuff for nearly 2 weeks with no response, I'm not sure what I need to do.

    I just want someone to say "ok we're on it!!!!" or "idiot, you're doing it wrong, fix this setting!"


    Something? Anyone?


    Just noticed an episode has been on my NAS now for 3 days and it's still not scanned into my library.

    British Bake Off, Season 10 Episode 1 - all of S9 is working fine (because it was scanned in months ago) - ever since I got 9.1.002 it's been giving me issues with the library.

    NOTE:!!

    2019-09-01 12:18:20.347 T:1524298624 DEBUG: VideoInfoScanner: Found episode match smb://freenas/media/tv/The Great British Bake Off/Season 10/The Great British Bake Off - S10E01 - Cake Week.mkv (s10e1) [s([0-9]+)[ ._x-]*e([0-9]+(?:(?:[a-i]|\.[1-9])(?![0-9]))?)([^\\/]*)$]



    Upon further testing *just like my problem with my movies* - it seems to me that an AUTOMATIC scan or a "scan for new content" will **NOT** add stuff to my library (or add it, incorrectly)

    If I do a full manual "refresh"" and "force" an update of the data, it fixes it. (The method where I need to *confirm* what it is, with the little pop up showing a list of matching items) *that* fixes it and it imports ok.


    I do not know why, I can recreate this consistently.

    PLEASE can someone else confirm a similar issue or tell me what I need to do to fix it?


    Thanks for the hard work



    I'm reluctant to nuke my entire library here... surely there's something I can do before that?

  • awiouy

    Approved the thread.
  • In the interest of helping others, I always like to update my posts.


    I hope this hits the google indexer and helps others, this was my fault but it was an IDIOT problem and took me several weeks to isolate.



    My Couchpotato (I think?!) wrote malformed / poor .NFO files for several movies.

    LibreElec (Well, Kodi) tried scanning in these movies and instead of doing a regular matchup of the movies, it used the (bad) NFO files.



    It was either this or the movie scanner configured for the oflder was "The Movie Database" NOT "Universal Movie Scanner" (IMDB set) - I'm pretty sure it was the NFO files though, I can't be certain if the Movie database was set as the identifier.



    So I hope this helps others, if a scan is failing, nuke bad NFO files.

    (Now to see if CouchPotato caused this with some testing :( ! ! )


    Thanks all