Wetek Play 1: Problems after auto update to 9.0.2

  • I didn't update my perfectly working LibreElec 7.x on my Wetek Play 1 for quite a while, but after the subtitles addon stopped working, it was time for me to upgrade. Unfortunately, after auto updating, several problems popped up which I wasn't able to resolve, even by doing a hard reset:

    - Video playback of some of the videos stutters heavily, I tried around a bit and this seems to affect all videos with some more complex kind of sound format (e.g. DTS and AC3), which also have no sound.

    - Probably related to that: All options from audio passthrough are gone. Right now there is my Samsung Q9FN connected via HDMI, and an Onkyo AV receiver connected to that. The weird thing is that when I bought this TV I had to turn off DTS passthrough, since Samsung does not support it, and the box was easily capable of transcoding the sound into PCM. And now transcoding does not seem to work anymore.

    - The Wetek remote is only working partly, especially the context menu button does not seem to do anything anymore. I also put some more advanced functions on the color buttons, this didn't work anymore either. I used the keymapper to reassign the color buttons, but somehow all of the color buttons give back the same key code, and nothing is working. This is especially painful because since the beginning of time CEC is not working properly on that box and I can't use my tv remote.

    - Stopping the videos (those which are still working) often makes the box freeze, looping the sound. I have to pull the plug and restart the box.


    So my questions are:

    - Is Wetek Play 1 still supported by LibreElec? I didn't see anyone else posting about problems with it, is somebody else still using it successfully? I general I could imagine upgrading to something more modern with x265 and HDR support...

    - Is there any difference between doing a hard reset and completely reinstalling a fresh LibreElec 9.0.2 on the box? Or would some new beta help me with my issues?

  • Thanks for pointing it out. I guess I will try CoreElec, then try rolling back to Libreelec 8.2.4 and if both does not work, I'll go for some new box...

  • The device is old, but unfortunately there is no newer device with 2 builtin DVB-S tuners on the market. :(

    Does Coreelec support the Play1?

  • Hey, would you share howto bring netflix to work? I need to install widevine CDM with 2,7GB, but there is just 2,1GB free space left on the play1. Any ideas how to hardware accelerate UHD x265 Material?

  • Hey, would you share howto bring netflix to work? I need to install widevine CDM with 2,7GB, but there is just 2,1GB free space left on the play1. Any ideas how to hardware accelerate UHD x265 Material?

    It's best to start your own thread