LibreELEC + Retroarch 9.80 for Raspberry PI 4 !

  • Newest build I cannot get Audio device working, it's greyed out and we don't have any other option besides bluetooth audio through pulseaudio.

  • Do I have to install it by writing directly to the sd card or is it possible to update an existing installation by throwing your image into the .update folder?

  • Do I have to install it by writing directly to the sd card or is it possible to update an existing installation by throwing your image into the .update folder?

    just like any LibreElec version except vanilla, you update by tossing either the .img or .tar into the Update foldervia network or on-device over a USB storage etc. i would say much like with 5schatten 's builds for the 2 and 3, w/ first time updating, flash the .img to the SD card rather than trying to update from vanilla "Lakka" , after that as above, is all good n golden to toss either archive into the Update folder.

    however if you start compiling updates yourself. big ones start from scratch (make clean & PROJECT=RPi DEVICE=RPi4 ARCH=arm make image ) initial/from scratch builds will take along time on older hardware/limited VM's so beware of that (on my System an AMD FX 8320E 16GB Ram, with a VM given only half that and a 120GB HDD Image. times are in the ballpark of 7 HOURS for a fresh image, significantly less when its a small update.

  • Hello I am a noob here but I flashed an SD card with your latest build Rpi4, played around works really darn good too. Had some issues changing skins, resulted in losing emulation station and retroarch selections on the main screen. I also noticed that upon removing main screen menu options on the original skin "Estuary", reboot brought them back. Also couldn't add media to their respective menu options "tv show" / "movies".


    I'd ideally like to work on some of this stuff myself and im going to look around the forums for faq's about building my own, I would like to maybe work with you on your project because it seems like you're headed in the right direction and very close to what I am looking for.


    Thanks for you work so far.

  • In Retroarch I am unable to download cores and there are no cores preinstalled either. How am I able to download them?

  • In Retroarch I am unable to download cores and there are no cores preinstalled either. How am I able to download them?

    is this the recent build he posted at my request? (edit tested on my Pi4, the only thing that indeed doesnt work is "Download a core" (which understandably wont work, No Pi4 cores reside yet on the libretro buildbot server, thus if you could, no core you downloaded or overwrote would launch)

    if you are using the 10/17/19 build, go hit the Releases , a new build was posted at my request to MagicSeb (again thankyou MagicSeb i still cant get a new VM up n running, a problem i'll haveto face when im back home X_X)

    Edited once, last by Cael ().

  • Thanks for the reply Cael.


    I installed the RPi3/RPi4 Release-Leia-18.4 yesterday from 11.08. Should I rather use the 2019.10.17-RPi2-3-4 and Rockchip RK3399 rrelease?