Odroic C2 with LE 9.0.2 /sys/class/gpio/ is not available

  • Hi everybody,


    this week I upgraded from LE 8.2.5 to LE 9.0.2

    All seems to work fine, but now I realize, I've got no access to /sys/class/gpio/


    I've got a second ir receiver connected via gpio and I have to set some gpio values.

    Have I to compile LE with some different settings, or what is my fault?


    Thanks for support,

    WebEye

  • Sry, hate bumping!


    But seriously nobody?

    I can't imagine nobody uses sysfs with Libreelec nor can explain, how to build libreelec to get this feature back!

    It's no problem to build it myself, but I need hint, how to enable sysfs.


    Meanwhile I tried CoreElec, they have still enabled sysfs, but I don't get warm with CoreElec and i love to have back my LibreElec ;)


    Thanks,

    WebEye

  • Have a look at the mainline kernel images for Amlogic. I've no idea if those are any better, but at least the codebase is worth looking into for changes if not. I've boot tested 5.2rc4 kernel on C2 earlier today (current images are 5.1 kernel but an update will come soon).

  • Thanks for support chewitt


    Never thought ist's an Amlogic issue, I thought the LE team has disabled sysfs intentionally!


    do you mean this ones: https://yadi.sk/d/dhepyyrcterlf

    e.g. LibreELEC-AMLGX.aarch64-9.1-devel-20190608144541-a41fdf1-odroid-c2.img.gz ?


    thanks again,

    WebEye


    PS: If you got a device with such an image, can you access "/sys/class/gpio"

    This would save a lot of time for me! ;)

  • Business trip is ok, but no toys? That's hard ;)


    Never mind, I will test it by my self this weekend!


    Thanks again....