'No Device found' trying to install on new Mini PC

  • Trying to install LibreElec 9.0.2 on a new Intel N4100 mini PC which uses a 64GB MMC for internal storage.

    When I get to the LibreElec install menu and choose install I receive the message 'No Devices Found'

    I tried to use G-Parted on a bootable USB with the intention of going in and nuking/remaking the partition, but I see a lot of errors when G-Parted tries to mount the drive, many errors saying "error -84 whilst initializing mmc card". If I use Hirens boot USB and choose any of the partition managers there, they have no problem seeing the storage and interacting with it however I like. I tried deleting and remaking the partition with those tools but still no luck with the LibreElec installer.

    Seems the installer/linux is unable to interact with the hardware itself rather than the way the partition is structured/formatted.

    How can I fix this??

  • Try running a Ubuntu Live disk and see if it allows you to do the initial stages of an install of Ubuntu.

    If it does then you could allow Ubuntu to install fully and then see if this makes your emmc recognizable to the Libreelec Install tool.