Nightly images for A20, A64, H3, H5 and H6 boards

  • Actually, I found an issue with latest nightlies on H6. For some reason, kernel crashes in all cases except if it is connected on 4K TV and enhanced colors are enabled - exactly the opposite I thought it would help. If enhanced colors are disabled or 1080p PC monitor is used, Kodi won't start due to kernel crash.


    I think that latest GPU driver has caused this issue, but I'm not sure how to fix it. Reverting driver change isn't an option. It will take some time...

  • Hello, I'm running this on the Orange Pi One Plus H6. And it's already performing a lot better than the Ubuntu or Android images that they provide. Thanks a bunch!


    I can see a lot of addons are available already, but no iptv addons. Do these still need to be build/ported? Or can I somehow enable those?

    Edited 2 times, last by Gyrth ().

  • Which build do you use? Are you using a 4K TV?

    I'm using this LibreELEC-H6.arm-9.80-nightly-20190628-bb9c865-orangepi_one_plus.img.gz
    And it's plugged into my 1080p monitor. Not sure what this has to do with iptv plugins though. :D

  • gamma-271 Can you also upload Kodi log (/storage/.kodi/temp/kodi.log)? Dmesg and console log seem to be fine. Unfortunately I don't have this specific board.

  • Hi to all :)


    I would try this build on my Pine64 A64+ but I think that the image available is corrupted. Even the sha file is empty and it's not possible to check the integrity. If I try to gunzip it, I receive an error. Even 7zip detect some archive error. Is it possible to download some previous image somewhere?


    Another thing a bit OT, does someone know how I could install the proprietary GPU driver on official Debian buster for Pine64+?


    Anyway thank you so much for this awesome OS.

    Edited once, last by pinexxx ().

  • Hi there, thought I'd give a bit of a feedback as an appreciation to your fine work. I'm running OPi One+ (H6) image. Works great in general. I've restored old Kodi backup from other SOCs, so I even managed to get simple IPTV working. Works fine on 3 of my TVs 1080 and 4K.


    Now downsides:

    * I have 1080 and 720 streams working just fine both HW and SW decoded. 4K and 572 do not work, both give the black screen. 572 decodes the sound OK while 4K does not.

    * While connected my SONY TV the sound is shattered. Like half of a second silence after every second of a sound. Other 2 TVs (Samsung and LG) do not have that artifact.


    Hope this is helpful someway, cheers

  • Also running into the image corruption. Been going crazy with balena trying to figure out why

  • A64 and other images will be rebuild in in several hours, so wait until then. H6 images are slightly broken and I'm working to fix this, but it will probably take few days.

  • I noticed there is no Russian language in Kodi settings, so it's impossible to select it. Attempt to select Russian in LibreELEC initial setup wizard does nothing - Kodi stay not localized.

  • I managed to make it boot from emmc using this instructions: Nightly images for A64, H3 and H6 boards