Nightly images for A20, A64, H3 and H6 boards

  • Hi, I downloaded the latest nightly for PineH64 but I cannot access the libreelec repository to download inputstream.adaptive as it cannot connect to the repo, I also have tried to manually debug this via curl by getting a 404 doesn't exist, Is there any way I can install inputstream.adaptive manually, if someone can please post a working zip for this image ?


    Code
    1. "curl https://addons.libreelec.tv/9.80.00 -v"
  • Hi, I downloaded the latest nightly for PineH64 but I cannot access the libreelec repository to download inputstream.adaptive

    You just have to wait until addon repo is rebuilt. As you might noticed, version has changed.

  • What does this statement by chewitt mean for our SBCs?


  • What does this statement by chewitt mean for our SBCs?

    It means nothing will change for the time being. We considered releasing alpha and maybe beta (but not stable!) 9.2 images for Allwinner project, but there are simply too many corner cases which don't work well or not at all. First stable images are considered for LE 10. Hopefully we can fix most or preferably all bugs till then.

  • It means nothing will change for the time being. We considered releasing alpha and maybe beta (but not stable!) 9.2 images for Allwinner project, but there are simply too many corner cases which don't work well or not at all. First stable images are considered for LE 10. Hopefully we can fix most or preferably all bugs till then.

    Great, I wasn't really sure if that would affect the nightlies as well.


    So no problem at all. Thanks :-)

  • Hi

    I have tried libreelec on my orangepi3 .Good work, it is working :) !

    Can someone can tell me how to make emmc working ?

    I have tried to do dd libreelec image file to my /dev/mmcblk2 .

    Partitions have been created correctly, but orangepi dosen't boot. I think that I have to install bootloader at the begin of the emmc. correct?

    Any tips for that ?

    Thanks

  • Hi,


    I just tried the OrangePi One Plus image from 25.06. but it does not boot. Seems to be a problem with hdmi:


    Code
    1. Starting kernel ...
    2. [ 0.253577] sun50i-de2-bus 1000000.display-engine: Error couldn't map SRAM to device
    3. [ 0.254133] sun4i-usb-phy 5100400.phy: Couldn't request ID GPIO
    4. [ 0.399913] sun4i-i2s 5091000.i2s: Max playback channels changed from 2 to 8
    5. [ 0.412280] sun4i-usb-phy 5100400.phy: Couldn't request ID GPIO
    6. [ 0.486362] sun8i-dw-hdmi 6000000.hdmi: Couldn't get ddc regulator
    7. [ 0.492635] sun4i-drm display-engine: failed to bind 6000000.hdmi (ops sun8i_dw_hdmi_ops): -517
    8. [ 0.501515] sun4i-drm display-engine: Couldn't bind all pipelines components

    I could also provide the complete uboot-log.

  • gamma-271 Actually, your boot log excerpt is pretty normal. Peripherals inside SoC are interdependent. You can't load driver if dependencies are not all loaded yet, which is what has happened here. This can be recognized by error code -517 (-EPROBE_DEFER).


    What you have to do is to edit extlinux/extlinux.conf on FAT partition and remove quiet and console=tty1. That way you will get complete boot log and if kernel doesn't crash, serial console. Please provide boot log after these extlinux.conf changes.

  • Ok, thanks for the instructions. Output of console-log is included, in addition output of dmesg. I also tried to boot the system attached to my monitor instead of the TV. On the monitor I at least see the initial LibreElec logo.

  • How do I install the image in EMMC memory?

    Just dd it on eMMC over ssh. Currently this is the only way (except for OrangePi 3, where a U-Boot update is needed).


    Is this of any relevance: Can't get HDMI out on OrangePi One on sunxi-next · Issue #290 · linux-sunxi/linux-sunxi · GitHub? I know that the issue is about Orange-Pi One, and I have the One-Plus, but the symptom is the same.

    Actually, it's not the same. In that issue report you can see reported -517 two times, but in your report it's only once, because second time driver loads properly. If driver mentioned in the issue wouldn't be enabled, then image wouldn't work on any combination of TV and board.


    Do you have by any chance 4K TV with enhanced colors enabled? If so, try disabling enhanced colors.

  • My TV is 1920x1080, my monitor is 4K. IMHO it does not make a difference. Same messages even if I don't attach any cable.

  • Just dd it on eMMC over ssh. Currently this is the only way (except for OrangePi 3, where a U-Boot update is needed).


    Actually, it's not the same. In that issue report you can see reported -517 two times, but in your report it's only once, because second time driver loads properly. If driver mentioned in the issue wouldn't be enabled, then image wouldn't work on any combination of TV and board.


    Do you have by any chance 4K TV with enhanced colors enabled? If so, try disabling enhanced colors.

    I am having a similar issue where my Orange Pi One Plus displays on computer monitors via HDMI but not on my 4K TV at all. I will try disabling enhanced colours and report back.