Help with Bitstream Audio on NUC 8

  • For the past couple of months I've been trying to get passthrough bitsream audio working with my NUC 8i7BEH coffee lake device and LibreElec. I upgraded to the NUC 8 to get HDMI 2.0 support so I could run 4K @ 60 fps. My AVR is a Yamaha RX-A3020 which has an HDMI 1.4a interface which limits it to 4K @ 30 fps. If I plug the NUC into the Yamaha receiver passthrough bitstream audio works fine for both DTS-MA and True-HD.

    In order to take advantage of the NUC's HDMI 2.0 output I bought an HDMI splitter which will send HDMI 2.0 video to my TV and HDMI 1.4 video / audio to my Yamaha receiver. This configuration works perfect with my Vero 4k+ running OSMC with Kodi 18.2 on it. I get 4K @ 60 fps with passthroigh bitstream audio. If I use the exact configuration with my NUC and LibreElec everything works perfect except passthrough bitstream audio for DTS-MA and True-HD.

    I've been trying everything I can to figure out the problem. Bitstream works when plugged into the receiver and the splitter configuration works fine when plugged into the Vero 4K+ but the splitter plugged into the NUC combination doesn't provide bitstream audio. I've attached a set of logs with the NUC plugged into the splitter and me playing the first few seconds of a video with DTS-MA sound. I am hoping someone can provide some assistance. Thanks in advance.



      (72.24 kB, downloaded 121 times, last: )
  • Instead of using an HDMI Splitter, have you tried using both outputs from the NUC (HDMI and Display Port) at the same time ?

    Maybe use the HDMI for audio output to your AVR and the USB-C (DP1.2) for the video to your TV ? You will need a USB-C to HDMI adapter cable I think. This is assuming both outputs work simultaneously.

  • I've tried that to no avail for bitstream audio. I also end up with menus disappearing in Kodi when I switch TV inputs away and then come back to Kodi. This thread has the details. When I look at the logs I see the proper formats being detected by Kodi, which aligns with the DTS-MA and True-HD settings being available in passthrough.


  • With your existing hook up, do you also have an HDMI cable connected from your AVR to the TV ? (If so, try unplugging it)

    Have you tried (for test only) a single HDMI connection to AVR and then from AVR to TV ? Do all HD Audio formats work then ? Yes, I know your AVR won't pass 4K but this is to test audio only.

  • I tried unplugging the AVR to TV connection and it didn't make a difference.

    For the test only configuration, that does work but is limited to HDMI 1.4a which is 4k @ 30 fps. This is what I described in the first paragraph at the start.

    It is acting like the NUC is not passing the bitstream audio to the HDMI output when connected to the splitter but it is passing non-bitstream audio. Since the splitter works fine with bitstream audio and my Vero 4K+ running Kodi, and the fact that non-bitstream audio works fine from the NUC points the problem back back to the NUC and I believe something in the Intel drivers. When I have passthrough bitstream enabled in Kodi and going through the splitter my AVD sees a 7.1 HDMI signal but just no audio comes out.

  • Does your AVR display DTS-HD or DTS-MA when passthrough is enabled ? Just for ha-ha's, have you checked to make sure the "MUTE" wasn't accidentally turned on in Kodi ? I have seen this before.

  • The AVR does not display DTS-MA or True-HD when passthrough is enabled with the NUC. It basically says thee is no sound coming in to map to a decoder in the AVR. Disabling bitstream for DTs-MA and True-HD maps it to DTS and EX decoders in the AVR. With the Vero 4K+ it shows DTS-MA and True-HD. No mute on Kodi.

  • I have a much older pair of Intel i5 NUC's and they handle all HD Audio Streams using passthrough with no issues. The fact that your Vero works means it's probably a driver issue. You should search for others that have the same model NUC as you and verify the audio issue before filing a bug report. You also have to remember that there probably aren't many others that split the audio and video into 2 directions and that using a single hdmi cable corrects the issue. If your AVR were up to date, the problem wouldn't exist, right ?

    Have you tried older versions of LIbreelec ?

  • I have a 5th and 6th generation NUC and they work fine with older and newer LibreElec but they run HDMI 1.4a. I went to the 8th generation NUC to get HDMi 2.0 which my older receiver doesn't support, hence the splitter which is much cheaper than a new receiver.. Since the NUC works when connected directly to the AVR running HDMI 1.4a, I don't know if the issue is because of something the NUC is seeing from the splitter (i.e. EDID but that looks normal) or because the driver has a bug when running in HDMI 2.0 mode. I suspect the latter especially since the Vero 4K+ works fine and the NUC does for non-bitstream formats. I can't use an older version of LibreElec because they don't have the Intel drivers for an 8th generation NUC. That's what got me here. I'd love to find someone who has an 8th gerantion NUC, running HDMI 2.0 with LibreElec and can tell me whether bitstream is working or not.

  • On a whim I tried the latest Milhouse generic build from May 9th and I am getting the same results. Researching further I found this thread where there is a comment with regards to passthrough issues and v5 kernels. I am trying to find a 4.19 kernel build and see if it has coffee lake drivers.

  • I've been thinking about that, at a minimum a TV which has HDMI 2.0 and supports DTS-MA or True-HD although most TVs don't supply those codecs.

  • On a whim I tried the latest Milhouse generic build from May 9th and I am getting the same results. Researching further I found this thread where there is a comment with regards to passthrough issues and v5 kernels. I am trying to find a 4.19 kernel build and see if it has coffee lake drivers.

    The official LibreElec 9.0.2 build (with Kodi 18.2) uses 4.19 kernel and works perfectly with my Intel NUC8i3BEK with HDMI Passthrough. Last Milhouse build with 14.19 also works perfectly (I think it’s build 311 from memory). Build with 5.0 kernel are bad for audio Passthrough.

    Don’t forget to set Kodi to sync TV to Source otherwise audio Passthrough will fail.

    I have NUC8 -> HDMI -> Denon AVR X7200WA -> HDMI -> Sony 4K TV (2018)

  • You might want to check on your receiver what type of audio signal it is receiving. When you enable the sync display option look at the notes at the bottom of the screen. It says that when enabling sync display passthrough audio is not used by the player, even if you have it enabled. You do get sound but when I check on my Yamaha receiver I am getting PCM audio vs. DTS-MA or True-HD. This indicates that passthrough is being bypassed. When I use my Vero 4K+ and do not enable the Sync Display option I see the DTS-MA and True-HD being delivered to my AVR.

  • You might want to check on your receiver what type of audio signal...

    Just to be clear. I’m talking about the Player setting: Adjust display refresh rate -> Always

    Apologies if I wasn’t clear in my original post with my loose description from memory.

    I’m definitely getting DTS-HDMA Atmos etc displayed.

  • I continue to work on solving this issue. So far I updated the goFanco HDMI splitter to the latest firmware and updated the Intel NUC to the latest BIOS, v71, which just came out last week. Neither have resolved the issue. I opened a ticket with the goFanco folks and they have been extremely responsive and are looking into the splitter software, specifically the EDID parameters which are being presented to the NUC. They sent me a utility today which I loaded on a laptop and hooked the laptop HDMI output to the Yahama AVR. The software then was able to query the EDID responses from the Yamaha AVR receiver.. They are currently analyzing the data. They did have been try some configuration changes which do manipulate the EDID being presented to the NUC. That did not work. Hopefully the EDID dump will be useful in determining the issue. Through all of this the OSMC Vero 4K+ continues to work properly but from what I can tell it has a more fixed EDID configuration and doesn't appear to learn all of the EDID information from the external sources, just some of it.

  • It's been awhile since I've updated this thread. I worked with the splitter folks and they provided some new software but I still wasn't able to pass bitstream audio through the splitter using my NUC and LibreElec, just with my Vero 4K and OSMC. I decided to treat myself to a new AVR and bought a Yamaha RX-A3080, which is a much newer model than my older Yamaha RX-A3020. With the new AVR I was able to remove the splitter and go full HDMI 2.0 with 4K @ 60 fps. That solved the problem. I am now getting 4K @ 60 fps with bitstream audio. It also allows my streaming TV, which is running through a Roku Ultra into my AVR to run 4K too vs. being limited to 1080P. It was an expensive solution but something I had been planning to do at sometime.