cma_alloc failed on latest raspberry pi 9.0.2 image

  • Hi all,


    Just done a fresh install of le9.0.2 on my pi3


    on every boot straight after the rainbow screen i get this message.


    cma: cma_alloc: alloc failed, req-size: 2025 pages, ret: -12


    can anyone know what this is all about.


    Thanks

  • Ok so update on this quick.


    It only does this when I disabled overscan from the config


    If I put a hashtag back Infront of the disable_overscan it doesn't appear on boot anymore.


    Only problem is I have to disable overscan for the system to fill my TV screen otherwise I get black boarders.


    Thanks

  • I'm unable to reproduce the issue here. Tried with a fresh 9.0.2 install on a RPi3B+ and checked both with disable_overscan enabled and commented out.


    Did you make any other changes to config.txt? If yes, please post your config.txt.


    Also please grab the latest log ZIP file from the Logfiles samba share and upload it here.


    so long,


    Hias

  • No that's the only change I made to the config.txt


    If I enable overscan I get that message at boot.

    If I comment it out to disable overscan I don't get that message.

    Thanks

  • Here is latest log zip.


    Ive also just done a fresh install again to see if that was the problem but as soon as I disable overscan I get the error again.


    Thanks

  • Thanks for the logs, I could now reproduce the issue, pinged the RPi folks and they fixed it in the kernel (so the next LE release should be fine).


    If I understood the code correctly the message is a rather harmless warning which you can just ignore for now.


    so long,


    Hias

  • So yeah as you might guess from my Name my soul Purpose is to tell you that this Problem still exists.

    only Thing i changed was the lightdm so it wouldnt boot in CLI but in Desktop.

    now it wont boot in Desktop ever again with the same exact promt as posted in this thread.

    had to reflash my SD and i used an older Image which i luckyli had laying around.


    autocorrect created this uppercase/lowercase mess. sorry for that.


    btw. i had been using the most recent raspian buster full Image on the Raspberry 3 a+

    now im back to stretch.


    i just want a goddamn pi that boots into Desktop.

    my other one is doing it just fine.


    probably wont be reading any replies.


    cheers

    Robert

  • probably wont be reading any replies.

    Have you tried booting Windows 10 on your RPi3 A+? That's another operating system we don't support here and which won't work either. /sighs


    For everyone else, this is fixed in kernel 4.19.50 in "LibreELEC 9.2" (released yesterday).