Lenovo M72e (tiny) - Error 1962: No operating system found


  • If you have another SATA cable try replacing it.

  • If you have another SATA cable try replacing it.


    I don't believe it's the SATA cable. I just installed ubuntu to see if there were any defects in the HDD or cable and it installed without a problem.
    I'll try another cable either way, although I'm not hopeful that it will solve the issue.

  • Well I've found a bandaid fix for the moment.
    After exhausting all options when trying to fix the issue, I finally decided just to install LE on a USB stick and run it from there.
    I went through the whole process and then booted into LE installed on the USB drive... awesome!
    What I didn't realize is that something happened with the boot sequence and I was actually booting into the PC's HDD installation, not the USB drive.
    I thought maybe the bootloader was fixed so I removed the USB drive and tried booting directly to the HDD again, but got the same error (Error 1962: No operating system found).
    So I popped the USB stick back in and now it boots every time into the HDD's LibreELEC.
    I removed the "Storage" partition of the USB stick to make sure that I was really booting into the HDD and sure enough it still works.
    I really wish I could find out why the problem was fixed this way, but for now I'll just be happy that it works.
    (I also tried formatting everything and redoing the installs in both locations to reproduce the fix, and it worked again)


    So to recap:

    • I created a USB Installation Drive with the USB Creator (USB Stick A)
    • Found a 4GB unused USB drive to use as the dummy setup (USB Stick B)
    • Booted into USB Stick A and ran Installer
    • Installed LE on USB Stick B
    • Installed LE on PC's HDD
    • Removed USB Stick A from the PC
    • Rebooted and kept USB Stick B


    I read somewhere on these forums that OE and LE don't like having 2 installations on one system. So I guess in this case it was in my favour.


    Thanks for all the help.

  • Good to hear you got it working somehow.
    If you boot with Ubuntu live you might be able to fix or change the bootloader to not have to leave the "dummy" USB drive plugged in all the time.


  • Hi there


    I had the same problem with 4 of these PC's and the problem with them is the bios.


    What bios version is on your PC ?


    Please let me know the version and i can make a plan to help you.


    Regards

  • Hi thesash,


    As mentioned before, I updated the BIOS to the latest version. So that wasn't the issue.


    For everyone else who might be experiencing this issue, I've finally found a permanent fix!


    The problem was that the EFI instructions on the system kept the boot information from my Windows install.
    There was an entry for the main HDD and so the EFI loader kept looking for that Windows install, which is why it kept giving the 1962 error.


    The fix for me was very simple in the end (once I figured it out).


    WARNING: This fix involves modifying the system's EFI boot instructions and can result in a broken system if not done properly (or in your case might break just because your setup was different than mine).
    Continue at your own risk!!


    Step 1: Create boot USB with LibreELEC USB Creator tool
    Step 2: Boot your system into the installation USB stick
    Step 3: Install LibreELEC as per the usual instructions
    Step 4: Reboot
    ----------------------
    Note: This is the point where my system always broke. I always got the Error 1962 here.
    ----------------------
    Step 5: Boot into the USB stick again, but this time run the LIVE version of LibreELEC (off of the USB, as though you were just running it in portable mode)
    Step 6: Go to the Kodi addons and install System Tools (the one that includes efibootmgr)
    Step 7: Run System Tools (which opens a Terminal window)
    Step 8: run 'efibootmgr' and note all of the bootnums (in the format of XXXX) that mentions Windows or anything that might be pointing to your PC's main HDD (where LibreELEC is installed)
    Step 9: run 'efibootmgr -b XXXX -B' where XXXX is the bootnum of the EFI entry. In my case, the culprit was 0016 so I ran ' efibootmgr -b 0016 -B'


    Step 10: run the following:

    Code
    1. efibootmgr -c -L "LibreELEC" -l "\EFI\BOOT\bootx64.efi"


    Now shutdown the PC and remove your installation USB disk.


    You should be able to reboot directly into LibreELEC now.


  • Hi


    Updating to the latest bios is the problem.


    I restored to an older bios and that fixed the problem.


    If you restore to bios F4KT18A there is no problem installing LibreELEC and no problem in the boot.


  • Hi SaulGoodman,


    Longtime Kodi user on windows box, new to LE and I had this exact problem, similar machine, no joy in the BIOS and am trying your bandaid fix.
    I have 4 x bootnum, i points to the harddrive, one to ?? and two to the USB install.
    I've tired by deleting the harddrive, same error 1962, tried the ??, again same error.
    Reinstalled, hardrive bootnum returns but the other ?? one is gone, still get the error.
    Any clues??
    [hr]


    BIOS update to 9SKT98A solved the problem for me.

  • I'm the original who opened this. Was surprised that it got this much attention. Great work on the work-around and the subsequent permanent fix. Seeing that my Kodibuntu install is no longer working, I decided to give libreelect another go and still got the same issue with the most current build. and remembered this post.


    So now I am in process of updating the BIOS of my unit to see if that indeed fixes the issue. The BIOS update as mentioned by junkyarddoug was just released on 2017-04-03. So hopefully this will fix it for good.


    Sooooo, I updated the BIOS and recreated boot stick from tool and got same issue. BIOS is now current as of 2017-03-28. I will have to try the work-around as posted by SaulGoodman