Issues with network shares

  • Hi,


    I have a FreeNas box currently serving my media via SMB shares. I've mounted these shares on LibreElec, and everything works perfectly fine. Media is discovered and everything is ok.


    My issue is that when the LibrElec box is rebooted, the media is inaccessible for a while after booting. This is annoying and is screwing with the way that the library is updated, as it seems to only refresh on boot. The thing is that, because the shares are unavailable, the media library never gets updated.

    I've also tried NFS and the same thing happened. I've already set the configuration to wait for network before booting, to no avail.


    Can anyone help me troubleshoot/solve this issue? I believe this is due to the fact that LibreElec box is having trouble mounting the share straight away, but I can't figure out why. The share is an SMBv2/v3 with authentication configured. I've also attempted this on a no authentication NFS share, with the same result.

    I was about to start digging through the logs, but I'd rather ask here to see if someone can shed a light on this problem. I've googled, but can't seem to encounter anyone with my issue, so maybe I'm doing something wrong?


    I'm running LibreElec 9.0.1 on a raspberry pi model 3+B. The Pi is connected via cable.


    Thanks!

  • Have you tried wait for network at boot from the LibreELEC configuration menu?


    I have to use this to mount my samba share before Kodi starts.

  • Two suggestions:


    a) locally mount the remote filesystem(s) via systemd mount files. This allows you to place a hard dependency on the local mount completing before the Kodi systemd target can start.


    b) manually update the library periodically after you add new content, not automatically on every boot.