Lost profile when upgrading to LibreELEC 9.0.1

  • Hi,

    I have been using LibreELEC for years, since the beginning.

    I have just upgraded my HTPC from 8 to 9 using a bootable USB key. Everything seems to work fine, except I seem to have lost all my settings: it looks like a brand new installation. I do not have my library, preferences, etc. anymore.

    Have I missed anything? Can I use my old profile or is it lost? Else it will allow me to start from a clean

    I had tried to upgrade "manually" by selecting the LibreELEC 9 channel when I was under LibreELEC 8, but it told me that the partitions had to be resized. So I downloaded the bootable USB key creator and here I am... 8)

    I cannot remind how I upgraded previously (e.g. from 7 to 8), but I do not remember such a problem.


  • I'd guess you originally installed OpenELEC which used a smaller boot partition size. The LE 7 > 8 update kept within the OE size limits so manual update via the GUI worked. The 8 > 9 update is larger and won't fit the OE partition size so the update will abort with a message saying the partition size is too small. The easiest way to solve that is following a simple "backup > reinstall > restore" sequence. From the description you've skipped the backup and simply reinstalled LE which overwrote the existing install (the USB is an installer, not an updater). While annoying, the positive is you won't be restoring back all the extra cruft that you inherited from the original OE install (loads of language add-ons that aren't needed etc.) and the accidental spring clean should have things running smoother than before.

  • Hi,

    Thank you for the explanation. This is exactly what happened :)

    I have almost reinstalled everything, I just have to find a new "socat" in order to feed my EPG to TvHeadEnd. I was using the version from an old OpenElec add-on...